BUG with Audacity 2.3.2 for MAC

when having about 4 separate stereo tracks in an AUP file and splitting one of those tracks in time and moving part of that track further along in time, using the time shift tool that small piece of the track disappears and audacity freezes and I have to force quit to exit program happened 4 times in a row I created a NEW AUP file copied each track over to the NEW AUP file with the exception of a label track that worked fine

I returned to existing AUP file that had crashed first I clicked on label track and deleted it then highlighted part of track and moved it fine then without highlighting part of track moved it fine again next undid all my moves and recovered label track highlighted part of track tried to move it froze when recovered tried to part of track without highlighting again froze

I deduced rightly or not that the label track below is causing the problem

Are you able to make the project that crashes available to us so that we can investigate the problem? (perhaps via dropbox or google drive).