Bug: Audacity 2.3.0 crashes on second entry to Manage Macros

Windows 10 Home, Version 1709, Build 16299.309
Audacity 2.3.0 alpha, build 20180320-91, 20180321-92

  • Click Tools | Macros
  • Choose macro that includes EQ, Normalize, Export to MP3
  • Click Files…
  • Select multiple files
  • Click OK
  • Click Save, OK for each file
  • Click Cancel in Manage Macros window
  • Click Tools | Macros
    Audacity Crashes

Thanks for the report.

A crash has previously been reported on Mac and Windows when the macro includes “Export to MP3”.
Could you test if the crash still occurs if:

  • You remove the “Export to MP3” step
  • If you replace “Export to MP3” with some other export
  • If you remove or replace the other effects from the macro to determine if the export step is the problem.

Here are results of the requested tests:

Export to OGG instead of MP3

  • Same crash
    Remove Export step
  • Equalize, Normalize
  • Same crash
    Remove Normalize step
  • Equalize only
  • Same crash
    Replace Equalize with Normalize
  • Normalize only
  • Same crash

I think this has alraedy been fixed the the developer who is working on Macros

See: https://github.com/audacity/audacity/commit/40085b384f48d097230f5dfee8786eb4eaa96c76


Confirmed: bug fixed; Build 96 works without crashing.

Thanks for reporting back Stuart - much appreciated.

Just be aware that the transition to Macros is still very much a work-in-progress - there are still a few" wrinkles" we have to iron out …

See this Wiki page: https://wiki.audacityteam.org/wiki/Macros_discussion_page


This is really wierd. It doesn’t happen for me.
I am trying to reproduce this error.

Best regards

Peter Storm

[Banned website]

This bug was reported for Audacity 2.3.0 which is the current alpha version of Audacity. Are you testing the alpha version, or just trying to spam the forum?

I’m still getting this crash. I’ve been applying a “Chain” that includes Equalization to five other files and it worked perfectly. Now I have a new project and can’t apply it. I’ve upgraded to 2.3.0 and still get the crash. I’ve also tried to simply record a brand new track in a brand new project and ONLY apply equalization (instead of the whole “Macro”) and it still crashes. Help?

Does it crash if you apply the Equalization effect directly (not from a Chain / Macro)?