boundary sectors errors

I tracked a wav file in Audacity using the “Add Label at Selection” and then “Exported Multiple” as FLACs. Trader’s Little Helper says these files are not cut on a sector boundary. I’m using Windows 7 and Audacity 2.02. How do I get these labels in Audacity at sector boundaries? I have tried messing with the “Snap To” but same result.

Are you sure that you need to? Many modern CD burning programs can fix these errors automatically.

If you really need to, then set the time units in the Selection toolbar to “CDDA frames”, and enable “Snap to”. When you make your selections to set the region labels, the selection will snap to CDDA frames.

Have tried these settings and “Export Multiple.” Trader’s Little Helper still says “audio data is not cut on a sector boundary (sector misalignment = 4 bytes).”

Import the FLAC file back into Audacity.
Set the time units to samples.
How long is the imported FLAC track (in samples)?

From the beginning, I started a new project with 24-bit / 96000 Hz (what the raw WAV file is), “Snap To” checked, “CCDA frames (75fps)” from the drop down list, and loaded the raw wav file. I added some tracks with “Tracks>Add Label At Selection”, changed the project Rate to 44100 Hz and exported 16-bit FLAC and WAV files using “Export Multiple.” I started a new project (16 bit, 44100 Hz), “Snap To” checked, and selected “samples” from the drop down list. I imported the previously exported FLAC or WAV file (into separate projects) and selected all data or just the end of the data. For both the FLAC and WAV file, Audacity says the files are 19,645,669 samples long.

OK, you must be doing something wrong because that is not an exact number of frames.

Try this as a test to see if we can get it working:

  1. Import an audio file
  2. Ensure that the time units are set to CDDA on the Selection Toolbar and that “Snap To” is enabled,
  3. Select part of the track.
  4. Ctrl+T to trim the track to the selection.
  5. Export as a Flac file (File menu > Export)
  6. Test the exported file with Trader’s Little Helper

Does that work?

Yes that did work. The above are my exact steps for tracks.

Yes this does work but on when the loaded file is 16-bit. However, TLH finds BSE when I load a 24-bit file, trim it, and export it.

OK, so try this:

  1. Ensure that the time units are set to CDDA on the Selection Toolbar and that “Snap To” is enabled,
  2. Import a track that is at least 2 minutes long.
  3. Select from the start of the track to about 1 minute and press Ctrl+B to create a label - add the text “track1” (without quotes).
  4. Select from the end of that labelled region to about 2 minute and press Ctrl+B to create a label - add the text “track2” (without quotes).
  5. File > Export Multiple. Export based on labels.
  6. Disable “Snap To” and open a new project
  7. Import the exported files back into Audacity and check the length of each in samples.
  8. Test the exported files in Trader’s Little Helper

What are your results?

loaded 24-bit file and followed previous steps results (exported 16-bit and 44.1 kHz):
track1 sample length is 18,734,787
track2 sample length is 5,331,985

Trader’s Little Helper results:
track1.flac: audio data is not cut on a sector boundary (sector misalignment = 4 bytes).
track2.flac: audio data is not cut on a sector boundary (sector misalignment = 4 bytes).


loaded 16-bit file and followed previous steps results (exported 16-bit and 44.1 kHz):
track1-16 sample length is 18,587,268
track2-16 sample length is 5,31,817

Trader’s Little Helper results:
track1-16.flac: audio data is cut on a sector boundary.
track2-16.flac: audio data is not cut on a sector boundary (sector misalignment = 4 bytes).

I expected track2 to be not cut on sector boundaries because of the ending. Seems to be a problem when the imported file is not 16-bit.

I can’t reproduce the problem.
Could you upload a file that is giving a problem somewhere on the Internet (such as Sendspace.com) and give step by step instructions so that I can reproduce the problem.