Blue Yeti RIght Channel Peaking

I’ve been using my Blue Yeti to record voice overs in Audacity. I first tried on my macbook and it worked just fine. As soon as I tried on my PC with the same mic, I started noticing terrible peaking/clipping even when talking normally.

I’ve tried backing away from the mic, turning the gain down, messing with the recording levels, swapping out the cables but none of it seems to work. Am I missing something?


What a puzzle! I’m thinking this is likely a hardware issue - perhaps with the Blue Yeti microphone.

You could have a defective USB port on your PC. I assume your PC has more than one port and that you have tried another. It could also be insufficient power in general from your PC. Do you have access to another PC where you could confirm this? If so, there is (very small) chance a USB Y-Power adapter cable could help.

Good luck. Post back what you find. :grinning:

Thank you for your response!

So it’s not an Audacity issue from what I’ve seen. I’ve tried different cables in different spots on my PC. Tried directly into the mobo, through the front USB ports, and even through a USB hub. Same issue all around.

HERE is an audio clip to give a better idea of what the sound is doing.

I’m honestly stumped why it would be doing this on my PC but not my Macbook. Maybe my mic is just showing its age at this point? (10ish years old).

I know this goes past Audacity help at this point, but the help has been appreciated!

Possibly better power available on the Mac ?


This topic was automatically closed after 30 days. New replies are no longer allowed.