Blue Snowball microphone stoppd working with Audacity.

I’m running Windows 10, it was just updated earlier this week and today is when I first noticed the problem, the microphone worked fine last week when recording. I’ve made sure all input/output settings are correct, the microphone is being recognized by my system, I just updated Audacity to version 2.2.? newest version today in an attempt to fix issue with no success. I tried updating the mic drivers, they’re current, And restarting the audio devices over and over to no success. I can hear it working through the listen option in audio devices so I know the mic is working, but it will not record, I just tried it in OBS to see and no audio was recorded even though I could clearly hear me talking through it and coming through my speakers while having the listen option on. I would really rather not spend money on a new microphone only to find out it’s having the same issue, I’ve gone through every tutorial I could find and tried everything, I really dont know whats going on here.

The current version is 2.3.0. It is available via the Audacity website:

Probably this: