Bizarre volume level issue with USB headset

Hey all,

I am pretty sure this problem is not specific to Audacity, but I was hoping someone here might be able to point me in the right direction as it really only impacts my ability to use Audacity.
audacity info.PNG
I have a Windows 7 x64 system, and am using a USB headset for my audio, specifically a Logitech G633 along with Audacity 2.1.2. When recording audio via the WASAPI interface, things work but the volume level is extremely low. I’ve done a number of searches, and so far nothing has helped, but in digging through the various Windows volume control settings, I noticed that even Windows is seeing the volume output very low (in spite of the actual volume output coming from the headset being very loud).

I am attaching an image of the Windows volume output that I was able to grab. On another computer those few pixels of green at the bottom of those bars would be almost the full bar.
low sound level.png
This has been a difficult issue to try and verbalize, but if anyone has any suggestions, I’d be very appreciative.

That seems an awful lot of work to record a headset. Are you capturing gameplay?


Exactly what audio are you recording? Have you tried playing the audio you want to record, then opening Volume Mixer as in your screenshot and turning up the volume slider for the application that is playing the sound?


I am recording audio that is being streamed via a tab in Chrome. My apologies, the screen grab I pulled showing the volume sliders was incomplete, but all volume sliders were maxed, but it also had no impact on what was getting captured.

As far as why I’m “capturing a headset”, I’m not. The onboard soundcard on my motherboard is faulty, so I am using the USB headset as my primary sound device.

Based on what I’m seeing on the volume sliders, I suspect all WASAPI captures will result in the same thing, which is why I’m hoping someone here might have some additional insights. When I capture game videos using Nvidia ShadowPlay, the audio volume captured there is normal, but I know that is going the DirectX route, which Chrome would not utilize.

OK. Read that multiple times. You’re sending the Chrome playback audio out to the headset and then turning it around and bringing it back in for recording.

That means, similar to doing the same thing with your broken soundcard, the audio is subject to the recording and playback services of your sound device. It’s a common complaint with a soundcard that you can’t turn your speaker volume down without messing up the recording.

Does the headset have drivers or other fancy sound services? Noise Processing? Surround? I would totally look there. You’re right. Anything you send down this pathway is going to have the same problem. Does the headset have an integral volume control like part of a dongle?


WASAPI loopback recording is usually at a fixed moderate level irrespective of how loud or soft the audio is, except that you must have the volume of the player in the web browser turned up.

Have you looked in the Logitech gaming software for some controls that may have a bearing on this:

Are you running Skype? If so you could try shutting that down in Task Manager.


Also are you trying to record the Chrome tab while recording the game video in the other software?

There is a DirectShow audio recorder called Virtual Recorder here:


Yeah I started out with looking through the drivers and software settings for the headset, but none of that makes any difference whatsoever, sadly. Skype is not running. I’ve reached out to Logitech also to try and get some ideas why the Windows level audio output is so low via this sound device.

My mention of recording gameplay is a completely separate use case unrelated to recording the audio stream through Chrome - I mention it purely because it appears to be isolated to just the WASAPI interface for doing loopback recording. If I could convince the stream to play through a DirectX based player, I almost guarantee this problem would go away, but sadly I do not know of any for the streaming services I am capturing audio from.

Appreciate the responses all, looks like this one is a dead end, sadly.

That is why I suggested that DirectShow recorder app You can’t use it directly with Audacity but you can record a WAV that you can import into Audacity for editing.

Does the headset create the same problem on the other computer you mentioned?


Sorry, I must not have explained that properly. Same computer, different audio/video source, different recording/capture software. The problem isn’t editing, it’s capturing the audio.

Scenario 1 (The problem scenario):
Attempting to capture audio from a streamed source. The only player for said source is web based, so that means Chrome, Firefox, etc, and will not utilize DirectX for producing the sound, so attempting to capture via DirectX will not do anything. (This is for personal use, and I do not plan on redistributing anywhere, but I am intentionally not stating the origin of the media in question for copyright purposes. Not trying to be cagey.) The problem is definitely related to how the audio device processes sound via its drivers, etc, in Windows, which is why both Audacity and the Windows Volume Mixer shows very low output levels (as they’re looking at the same source material, very likely through the exact same interface). Unfortunately, the maker of the device does not respond to support requests (Logitech). They rely on the fact that their products generally just work, and so do not bother investing in actual customer service, which is horrible, but a fight for a different time and place. I figured the folks here might have more experience with the WASAPI interface and how to potentially convince the audio device to produce higher audio levels at the WASAPI level.

Scenario 2 (This works):
Same computer, same audio hardware (but irrelevant as you will see shortly); playing a game that is utilizing DirectX to produce both audio and video, along with the Nvidia ShadowPlay capture software, audio is captured at an appropriate level. The major difference here is that the audio processing is not actually being done by the audio device, but rather by DirectX, and then the output is being run through whatever audio device is in use. If I had a way of forcing the stream to playback through a DirectX player, rather than through the web player, and utilized that as the source in Audacity, I pretty much guarantee the capture levels would be as expected, given what I have observed and what I understand about this situation.

If any of that helps clarify things, awesome; if not, please let me know and I will do my best. I suspect the only ones who will be able to actually fix this issue are going to be the ones that refuse to respond to me, lol (i.e. Logitech), as they have no vested interest in making any improvements for a scenario that they likely do not consider to be important to their product. (i.e. Loopback audio capture) I can try boosting all the levels in the virtual EQ, but suspect that will produce distortion and other undesirable side effects.

Anyway, thank you for your patience and responses. :slight_smile:

But you haven’t said if that standalone DirectShow recorder records at a higher level. If it doesn’t then the problem may be something else. Or can you not record the browser audio with Nvidia ShadowPlay? Why do you have to use Audacity to record?

I think most likely the problem is in the Logitech gaming software, you just have not found the setting yet.


Sorry, I tried to explain in my previous post why this wasn’t even an option. Any DirectX recorder (like the DirectShow recorder you linked to) will not record things that are not being played back via DirectX. (like a game, etc) Streamed media coming in through a browser do not run through DirectX (DirectShow/DirectAudio/etc), so a recorder for that will not be able to capture it, hence using Audacity to capture it via the WASAPI interface where the audio is actually being produced. I will have to check the ShadowPlay settings to see if it has any ability to capture non-DirectX sources, and extract the audio from it. It is less that the issue is the LGS, and more it is inherent to how the headset processes audio within its driver and its interaction with Windows.

I am pretty sure I know where the problem is, this was more of a request to see if anybody knew of any workarounds for situations like this.

I don’t believe that is correct. I’ve just used that app to record from a Chrome browser tab using stereo mix of the built-in sound card (which you don’t have) and using its “Virtual recording device” which uses WASAPI loopback to record from the Windows default playback device.

I don’t think it would hurt to try it.