Bizarre playback error in Audacity 2.0.5

I’m editing a long (nearly 2 hours) recording of an interview down to a manageable size, which involves cropping and cutting out irrelevant parts of the original audio. After importing the .wav file, I selected and deleted a large chunk of about 45 minutes at the start of the recording and saved my progress. Now when I play back the audio (and even when I export it as a .wav file and play it in another media player), it plays a loop of the first 3-4 seconds (after the point at which I cut it) over and over, rather than the full recording.

It’s not a ‘loop’ in the traditional sense as it’s not the exact same length of recording that is repeating - it might, for instance, play the first 4 seconds, then the first 2 seconds, then the first 3. As far as I can tell, there is no loop function switched on, and the progress bar is showing the playback progressing as normal. The waveform shown onscreen doesn’t correspond with what I’m hearing either (i.e. it has too much variation in it to just be the same snatch of audio repeating itself).

I’ve hunted all over the forum and can’t seem to find anyone else experiencing this issue - does anyone have any idea what might be causing it?


Should add that I’m using Windows 7, in case that’s important.

It sounds like you are out of disk space or the drive you saved the project to is corrupting itself.


Thanks Gale, I have nearly 1TB of free disk space (I’m using a networked computer at work), so it’s definitely not that. I’ve had no error messages for the file corrupting itself, so I’m inclined to think that it’s not that either.

Audacity doesn’t work over a network particularly well. It doesn’t understand network delays and negotiation. Any chance you can edit locally and then move the work to the network drive?


It’s not a good idea to save projects or set the Audacity temporary directory to a networked drive.

It’s a terrible idea to record to a networked drive. It’s too slow.

Use a local or external hard drive.

Look at Help > Show Log… . Are there errors there?

What happens if you Edit > Undo back to where the recording completed? Are there holes in the recording?


Thanks both, will try disconnecting from my network to do the editing. The Audacity programme, directory and projects are saved to my C: drive, I’ve only been importing/exporting the .wavs from N:. Perhaps I was rash in choosing to read the files directly from the original, rather than making a copy before editing?

Gale, the first thing I tried when things started going wrong was to Edit>Undo back to the point when I originally imported the file, but the same error happens when I try playback after doing that (I played back the recording when I first imported it to check it was the correct one, and at that point it was playing fine, so it wasn’t an error in the original file).

I’ve just looked at the log and there are a few errors in there, but they all seem to be from before I first imported the file:

11:59:36: Error: Failed to load shared library ‘avformat-52.dll’ (error 126: the specified module could not be found.)
11:59:36: Loading avutil from ‘avutil-50.dll’.
11:59:36: Error: Failed to load shared library ‘avutil-50.dll’ (error 126: the specified module could not be found.)
11:59:36: Loading avcodec from ‘avcodec-52.dll’.
11:59:36: Error: Failed to load shared library ‘avcodec-52.dll’ (error 126: the specified module could not be found.)
11:59:36: Loading avformat from ‘avformat-52.dll’.
11:59:36: Error: Failed to load shared library ‘avformat-52.dll’ (error 126: the specified module could not be found.)
11:59:36: Error: Failed to load FFmpeg libraries.
11:59:36: Error: Failed to find compatible FFmpeg libraries.
12:02:30: File name is N:SupportProjectsMembersMarketing EngagementAudio 170714 (part 1).WAV
12:02:30: Mime type is *
12:02:30: Opening with libsndfile
12:02:30: Open(N:SupportProjectsMembersMarketing EngagementAudio 170714 (part 1).WAV) succeeded

I suggest you open Edit > Preferences: Directories and double-check that the Audacity temporary directory is set to somewhere on C:.

It’s possible that is the cause of the problem somewhere along the line, but if your Audacity temporary directory was also on N: that could be a problem too. So as standard practice I recommend “copying in” the WAV and using C: for the Audacity temp directory.

Where is your AUP Audacity project saved? N: or C:?

Are you seeing errors in a dialogue window about missing external files when you play the project?

Is “N:SupportProjectsMembersMarketing EngagementAudio 170714 (part 1).WAV” the file you were editing?

At this point I think the project data is corrupted. Can you ensure your temp folder is on C: as above? If it already is, File > New then import the file again from N: but choose the option to copy in the file. Export the file as WAV to C: as a backup then save the project to C:.

If you have to change the temp folder, close the faulty project, saving changes or not as you wish, restart Audacity then import the file from N: using copy in then export and save to C: as above.