Big Sur, Audacity 2.4.2 does not recognise "Super USB Cassette"

I have never used Audactiy before until I just bought a “Super USB Cassette Capture player”. It is not working to capture audio on my Mac so I am hoping for some direction. I am running Big Sur 11.2 and my Mac does not recognize the player. When I go to system preferences/sound is see a “USB pnp Audio Device” but it flashes and then disappears from the menu before I can chose it. I tried also on an earlier version of Mac OSX with the same issue. Appreciate any help to try and solve.


Do you have a receipt? Can you send it back?
If you look through this forum you will see many Mac users complaining that “Super USB Cassette Capture player” does not work well, or at all on Mac. They are very cheaply made devices and even on Windows (where they usually work for a while) they don’t tend to last very long - often only a few weeks.

(Forum search results:[]=47&sc=1&sf=all&sr=posts&sk=t&sd=d&st=0&ch=300&t=0&submit=Search)

I’m having a similar problem with Super USB Cassette Capture. It works with GarageBand (which I hate), but not with Audacity. I have selected USB PnP Audio Device as the input, but no sound when I play the tape. I understand these are cheap players, but it works with GarageBand and not with Audacity?? Any other suggestions?

Are you able to record in Audacity from other sources, such as from the built-in mic (if your computer has one)?

I am open to using another device on my mac but not familiar with other inexpensive options. Do you know of one that might work? Thanks for any suggestions.


Does your mac have a built-in mic? (most laptops do, but the Mac Mini doesn’t). If you are unsure, please say which model your Mac is.

Gary, many people are using an inexpensive USB audio adapter such as the Behringer UCA202 or UCA222. I think either one would do the job. They are priced at around $30, but you may be able to get one from Sweetwater for about $19. You would also need a 1/8" to rca stereo cable.

I hope this helps. :smiley:

Thank you for your suggestion! :slight_smile:

I am seeing the exact same problem. I connect the USB cable and in the Settings->Sound->Input window I see USB PnP Audio Device for a few seconds, then it goes away, and returns a few seconds later, goes away, returns … Pretty useless. I’ve tried different USB cables and tried it on a macbook pro running 10.14 and a mac mini running 10.12.
I have only a few cassettes to convert, so I will use the headphone output and run it into the stereo line-in on my mac mini and capture using Audacity. But what a piece of junk.
I realize I’m not offering any help, but I wanted to confirm that this is a common problem with this device.