Behringer UMC-202HD not on the list.

Linux Kernal: 4.19.0-13-amd64
MX-Linux: MX 19.3 (patito feo) (Debian)
Behringer UMC-202HD
Audacity 2.3.2 (installed with Synaptic)


My interface is working correctly.
It is plugged into my computer’s USB port.
Microphone input level is correctly adjusted on the interface.
I am using the most often downloaded, most popular Linux distribution there is, this week.

Have I done something wrong so far?

Audio input works very poorly, but Audacity does record with EXTREMELY LOW, unacceptable playback level, but ONLY on the meters. I can hear nothing through my phones on playback.

I have adjusted the interface and Audacity input level to correct settings.

I have followed configuration advice from several Google searches, but the illustrated drop downs and options are very DIFFERENT than on my installation.

I tried to paste a screenshot of my configuration, but Linux evidently doesn’t allow that. Sorry, not my fault!

Anyway, input is working, to some extent, but very badly.

Audacity playback is not working AT ALL.

When I try to select an audio output device, my USB interface is not on the list. Is there a way to select USB playback devices?

Playback is totally dead. No sound whatsoever through my phones on Audacity, but streaming sites play back correctly through the interface. Audacity playback seems to be the only exception.

Question: Exactly WHY is USB audio playback so damned difficult in Linux? it works well with everything else, but not with audio editors and DAWs.

How do I fix these two problems?

Finally, I am NOT a programmer or IT expert. I don’t know anything about the command line, and I don’t want to use it – at all. Every time I have tried to even copy/paste commands, something goes wrong. My system has been “bricked” several times! All those cryptic commands scare me. I am afraid of the command line. and it is a significant barrier to many casual Linux users. I have already heard all the enthusiastic reasons why it is “better” than a GUI, usually from users who have college degrees or years of professional experience.

On the other hand, I do have extensive experience in professional audio, and I need to set recording levels as I see fit. Without the program developers getting in the way of “best industry practices.”

I have been working every day for at least a week on these problems, on several Linux audio programs. None of them record and play back audio correctly. Some programs don’t even try!

I don’t understand!

Sorry for being so wordy. I just wanted to supply all relevant observations.I hope make myself understood.

Thank You.

I’ve split your post from the other topic as it is about a different problem with a different device.

This is the first thing we need to attend to. If you can’t select the audio device then it won’t work.
Try this, in this exact order:

  1. Log out and back in again (or reboot the computer
  2. Connect the UMC-202HD to the computer
  3. Wait for 30 seconds
  4. Launch Audacity
  5. Look in the Device Toolbar for “USB” options in both the Recording and Playback settings.
  6. Plug your headphones into the UMC-202HD.
  7. Set your levels
  8. Make a test recording.

See here for how to attach files to forum posts:


I followed your instructions, and it works and sounds good. Nice Job of explaining what to do.
Also, I really appreciate that it didn’t use the command line. I’m really scared by it!
If it’s not too much trouble, could you please explain what was wrong?
Thanks again.

The command line can look scary. I actively avoided the command line for a long time.
I think the thing that makes it look scary is that at first it’s just “magical spells” that we don’t understand.

I now use graphical apps most of the time, but for some tasks I use the command line because for some tasks it is quicker and easier than using a GUI app. One example where using the command line is easy - listing files in a directory:

Say that you have a huge number of files in in your “Music”, and you want to find one specific file - you don’t remember the exact file name, but you know that it is a “.flac” file. What I would do:

  1. Open my file browser
  2. Right click on “Music” and select “Open Terminal Here”
  3. In the Terminal:
ls *.flac

That will list (“ls” command) all “.flac” files in the current directory.

Even if you mostly use GUI apps (as I do), I think it is well worth the effort to try and understand command line solutions to problems when they crop up. Just knowing a few commands can save a lot a time in the long run.

My “guess” is that you previously launched Audacity before connecting the Interface.

When Audacity starts, it scans the sound system to see what devices are available. If you connect (or disconnect) a device while Audacity is running, Audacity is not aware of the change, so when you connected the UMC-202HD, Audacity did not know it was there, and was actually using some other device (built-in microphone?) and not the UMC-202HD.

If you connect (or disconnect) a device while Audacity is running, you must tell Audacity to “Rescan Audio Devices” so that it can see the change.
“Transport menu > Rescan Audio Devices”

Thank you very much for the concise answers.
This fix has worked well for me – several times. My system seems to “forget” about my USB interface. I then have to reconnect it.
Anyway, everything is working well enough now…

Perhaps a dodgy USB lead or USB socket?