Behringer UCA222 to Audacity

Hi, I’m hoping this is the correct forum to post this on and someone can help me.
The problem I’m having is I’ve just recently got a Behringer UCA222 Audio Interface and have tried hooking it up to Audacity. In the drop down menu for choosing the input the UCA222 is not there to connect to it. I’m using a Chromebook with Audacity going through Linux. I had a Lexicon Alpha Audio Interface before and all I needed to do was plug it in and it would override the internal microphone on my Chromebook on the Default input, I thought the same would apply to this Behringer UCA222 but when I press record on Default now it’s just using the internal microphone and recording the room.
I hope that makes sense to someone and I can get help even if it’s to say that it’s not possible for the UCA222 to use on a Chromebook at least I’ll know.

I’ve never used a Chromebook, but most Linux desktop distros provide a volume control near one of the corners of the display, which allows you to open the “Audio Mixer” (sometimes called “PulseAudio Mixer” or “pavucontrol” or something else). That “mixer” allows you to select which physical device will be used as the “default” device.


Hi Steve,
I have the UCA222 set up so that whenever I listen to music in YouTube etc it’s via the UCA222 so it’s working when connected to the Chromebook fine. It’s just when I try to get it to work in Audacity I can’t find it in the input menu to select it like it’s not compatible. I thought it would just be like my other Audio Interface (Lexicon Alpha) and work just by plugging it into the USB. With the Lexicon Alpha I didn’t have to select anything it did it automatically when plugged into the Chromebook. But right now, it’s just the inner microphone that’s selected in the default as when I press record in audacity it’s recording the room.

I use a UCA-202 (very close cousin to the UCA-222) with Audacity on Linux. There’s no “compatibility” problem for me.

That’s the “Output device” correctly set up. Now just do the same for the “Input device”.

Hi Steve,
I’ve just looked at that.

The Input only has one option: Microphone (Internal)

Whereas the Output gives me 3: Speaker (Internal)
Orion (HDMI/DP)
USB Audio CODEC: USB Audio: 1,0 PCM (USB)

I have the USB Audio CODEC selected on the Output but can’t select that as the Input as it doesn’t give me the option. I don’t know why I’ve not got the option on the Input like I have on the Output.

Is that in the system mixer (pavucontrol)?
Audacity can only access devices that are available from the system.

That’s the Audio Settings on the Chromebook where you can select the Output and Input device. As I say I don’t get why it has the option of selecting the Behringer UCA222 for the Output but not for the Input.

As I wrote previously, I’ve never used a Chromebook. Google throws up a couple of conflicting opinions.
From 2022:
but from 2020:
I’d recommend doing further Google searches.

Thanks for all your help Steve. Looks like I’m going to have to bite the bullet and get a laptop that runs windows as it seems I’ve tried all the avenues here with no success.

or Linux. As I wrote previously, the UCA-202 works great on my Linux laptop (I use Audacity 2.4.2 and Xubuntu 22.04).

On Chromebook Audacity isn’t meant to work. This is one of the Google searches I did earlier this year when I got a Chromebook and tried to install Audacity.

You cannot run Audacity on a Chromebook because Audacity does not support Chrome OS. Chrome OS 69 or later support running containerized Linux.5 Oct 2022

BUT…. there’s a way around installing it, which I did and has worked fine up until I had to get a new audio interface (UCA222) as my Lexicon packed in.

The Audacity version I’ve got is an older version as the installation process I followed to install it on a Chromebook said this:

“This installs v2.2.2 of Audacity, not the latest one. There’s not much you can do about that”

I get the feeling it’s a bit dodgy and is probably why I’m having problems. For instance it doesn’t even have the preferences tab for choosing your preferences and is also a way of choosing what input device to use for recording, there is some other stuff missing too.

I have UCA202 running with Audacity on Chrome OS out of the box. I used the Appimagefile for Audacity 3.1.3 to install to Linux. Then when the USB connection is made to the
computer, Chrome OS audio out goes to the UCA202. To get the input to work, you MUST enable the option
Allow Linux to access your microphone in the Linux environment development page under Developers in Settings. The default settings in Audacity work fine, just click to start monitoring to see the signal. UCA222 should be the same.