Behringer UCA202 don't seem to connect to Jack [SOLVED]

Hi,

I have tried to run Audacity2 out of Ubuntu-Studio 14.04 ! The first time I started Audacity, I was able to record from the UCA202.
The next day I returned, I started JACK, but Audacity did not recognize it anymore. I am helpless !

This is my config:
cat /proc/asound/cards:

0 [IXP            ]: ATIIXP - ATI IXP
                      ATI IXP rev 2 with ALC658D at 0xfe02a000, irq 17
 1 [CODEC          ]: USB-Audio - USB Audio CODEC
                      Burr-Brown from TI USB Audio CODEC at usb-0000:00:13.1-2, full speed

cat /proc/asound/pcm:

00-00: ATI IXP AC97 : ATI IXP AC97 : playback 1 : capture 1
00-01: ATI IXP IEC958 : ATI IXP IEC958 (AC97) : playback 1
01-00: USB Audio : USB Audio : playback 1 : capture 1

arecord -l:

**** Liste der Hardware-Geräte (CAPTURE) ****
Karte 0: IXP [ATI IXP], Gerät 0: ATI IXP AC97 [ATI IXP AC97]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: CODEC [USB Audio CODEC], Gerät 0: USB Audio [USB Audio]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

lsusb:

Bus 001 Device 007: ID 154b:6545 PNY FD Device
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 003: ID 058f:9360 Alcor Micro Corp. 8-in-1 Media Card Reader
Bus 003 Device 002: ID 08bb:2902 Texas Instruments PCM2902 Audio Codec
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 046d:c05a Logitech, Inc. M90/M100 Optical Mouse
Bus 002 Device 003: ID 04d9:1603 Holtek Semiconductor, Inc. Keyboard
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

.jackdrc:
used to be:

/usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2 -C

but it now:

/usr/bin/jackd -dalsa -dhw:1 -r48000 -p1024 -n3 -C

How did you do that? Are you using QjackCtl ?

yes I did!
But I am not sure what to select from the Device-Toolbar in Audacity

In QjackCtl “Setup”, ensure that your UCA 202 device is selected for both input and output (if you click on the “>” next to the selection box it will probably list it by a sensible name).
Then start Jack.
The main QjackCtl interface should show that Jack is running.

Then Open Audacity.

In the device toolbar, select "Jack Audio Kit as the “host”.
By default the input and output devices will then set to “System”.

Warning. If you click on the meter bar in Audacity now, Audacity may crash.
Press the record button, then stop, then undo or delete the track that was created.
Audacity should now be stable.
I don’t know why this little dance is necessary - some small bug when connecting to Jack - but this workaround works for me.

Hi Steve,

thx so far I’ll give a shot and will come back to tell wheter it worked or not.

cheers,
gretsch61

…up and running now!