Basic Overdubbing

I’m very new to Audacity and need help with basic overdubbing.
I record guitar on the first track. I put on my headphones and get ready with another instrument
Then shift-r a new track.
But the first track gets recorded onto the second track.
That’s not what I want. What am I doing wrong?

See this tutorial in the manual.
– Bill

Bill thanks.
I’ve read that tutorial a number of times and followed the steps but I still end up with the first track copying itself onto the second track.

Is Software Playthrough turned off?
– Bill

You have to be recording from a real thing, not a fake software device. If you like recording from the internet, that’s the exact setting that needs to be changed to get Audacity to overdub.

For old example, Soundflower was a program that allowed Macs to record internet music. Soundflower isn’t a real thing you can pick up and taste. It’s a fake software device that folds internet music back down the recording pathway. If all you did was Run Audacity and start overdubbing, you would get the backing track added to your voice or whatever the second instrument is.

Look at the recording device in the toolbar? Is that your microphone or something you don’t recognize.


Thanks for replying. Are you basically saying I can’t simply use the laptop’s in built microphone? I have to plug in a proper microphone?

I can’t simply use the laptop’s in built microphone?

You can use that or any microphone, but it has to say so in Audacity Recording up in the tool bar.

Screen Shot 2019-03-14 at 05.27.12.png
That and Audacity > Preferences > Recording should have [_] playthrough… not selected.

There’s a mechanical requirement, too. You must be wearing sealed-against-the-head headphones for overdubbing.

Overdubbing is one of the places we have had failures. It’s possible to have computer sound services so messed up that none of us could sort where the backing track recording path was coming from.


Thanks again for replying.
I’m not getting anywhere with this - I do exactly as you say - built in microphone selected - software throughput not selected - proper headphones - but am still getting the first track automatically on the second track. Apologies for being slow.

Apologies for being slow.

All of us get interrupted by Real Life.

I’m trying to think of other ways to test this.

The basic computer sound system has two pathways.

– Computer playback out to the speakers or headphones. Full Stop.

– Then there’s computer recording from microphone or other audio connection into the computer for recording. Full Stop.

There is no natural connection between those two.

It is insanely popular to provide a cross-connection so you can record YouTube Playback (for example) into an Audacity Recording.

Sometimes those connections arrive without you calling them and they are a real problem to get rid of. They can prevent successful overdubbing.

The only other generic thing to try is Shut down the Mac, (not restart) wait a bit and then Start.


Ok. Will do.

Thanks everyone.
I’ve tried everything.
I just can’t seem to be able to carry out the simplest of overdubbing.
I guess I’ll try some other software.

I guess I’ll try some other software.

If you get something to work, post back. Particularly if you try something else and it doesn’t work.

I just can’t seem to be able to carry out the simplest of overdubbing.

It’s not that simple. Audacity support elves across 9 time zones can’t fix it either.

Do you want to try one other thing?

Turn off Both Playthrough and Overdub in preferences.

Record one track. Just press record and play or speak.


Now do it again. If you press Shift-Record, the newer Audacity version should produce a new track under the old one. That’s the goal.

Did you get just the second voice, or the second and first voice mixed on the second tack? You need to press SOLO on the second track or Audacity will try to play both tracks together.

What did you get?