Backspace Key - stopped working

I am using and have been since available,
Linux Mint 18.3 ‘Sylvia’ MATE 64-bit
Audacity 2.3.3 just loaded 01July2021 from the Linux Package Manager

  1. What happened, - all was well and had been for several years, and of not updating Linux Mint, then did. I was always “conservative” and selective. Then, about two weeks ago or so, decided, well, they’re on Mint 20.x and have not seen any issues, so updated all. All went well, no problems.

However, then in Audacity, the 1.x version, default with Linux in the Package Manager, - then when I for example went to change a Track Label, Name I could not “Backspace” [Key] over the text. - Annoying but didn’t think much of it. Then notice the same in the Meta Data when exporting.

What I did was Mouse Pointer caught text, and what was highlighted was changed, corrected.

– So, to find fault with Audacity or, Linux as origin I needed to use all more for a while. And, did allot of Searches in every way possible about a Backspace Key not working. - Nothing. Backspace works ANY other place, software.

So, I rechecked for updates on Linux, - fully up to date as of today, - all.

  1. So…
    I went to load the latest version of Audacity and only just now see the 2.3.3 version come up (it never came up prior as an option), – in the Package Manager (Software Mgr, same, since just shows what I have loaded now, showed only the 1.x prior to update.)

So I proceeded and, I deleted/removed the prior version of Audacity, and loaded 2.3.3 and checked the Backspace Key, - still, same issue, - will not delete Text in the Label Box, will not back over anything, and the Arrow Key does nothing, too. So, I am thinking there is an issue with some driver with my “msi” Intel Corei7, NVIDIA GTX950M, - drivers, etc.

I can live with it, but if do not have to, why do so.

I have done all already online stated that anyone may find (nothing here), - even deleted/renamed the config file to generate a new one, etc. I went into the Preferences and looked up Backspace and is the Delete Key. In the prior Audacity, tried reentering and etc., - no change.

So, I live with the typos in Meta Data and Labels :slight_smile: or Mouse Pointer highlight to correct, or there’s a fix. So, Linux Mint had an update in some “peripheral” item (and why I don’t update stuff) and I did not catch it soon enough to then try degrading whatever it may have been, I guess, and oh well.

When I searched here now, the sight just sat there and was grinding away on “Backspace” (search waiting), or any combination and got a “500” error (to me is a permissions error?). So, I signed up, - same, grinds away and then “500” errors.

So, I post a new topic since don’t, can’t know if exists already.

So, if there’s a fix, let me know. I realize I may have needed to upgrade to 2.3.3 to even get the 3.x available now? And, so I have. I’m not interested in “just upgrading” (I was quite happy with 1.x actually - I don’t use plug’ins and etc., as a 1+1 “demos” only recording), – and, since so many changes now done without asking first, so will wait.

  • And, fyi, I tend to only load via the Package Handler since if from there, is typically - stable in every way. So, if 3.x is the fix, well, I may then, wait until shows up in the Linux Package Handler. Linux Mint 18.x is supported through 2021 prior needing to update to 20.x I just read through, unless someone here has further with reference links?

Okay then, thank you! (I may not be back “here”, fyi, right away, - I don’t “lurk” and keep checking; wait a few days and give folks a chance to see and say, etc. - fyi. I am hoping if I get a response your systems will email me a notice, having selected that below.)

I’ve no idea why your backspace key is not working. I’ve not encountered anyone else having that problem.
Perhaps you can work around the issue by clicking to the left of the characters that you want to delete and then use the Del key.

Thank you, I appreciate that.

As you likely can infer, - that’s why I wrote what, as, I did.

Yes, as you say, but that does not work.

  • One has to sweep from Right of the text, into the label. And, one has to hit the Space Bar or type to replace the text. Oh, and didn’t mention that the [Enter] Key does not work either :slight_smile: hahhh… I’ve notice “intermittent”, “workings”, during Metadata when exporting.

I suspect it’s a, Me, not You issue. When I purchase this MSi Laptop, it was commented as “quite good” and has been. It had Windows 10 when provided which I immediately formatted off, and replace with Linux Mint, Sylvia. All went well aside for the 50/50 NVIDIA driver boot thing, fixed easily as that went. It has been a great Laptop for a good while and considered replacing it. However, for my needs, I still, cannot buy better than what I have in what it is and has a CD-ROM drive too, still, which I need. The Intel Chip, in my experience seemed to be the way to go if only for down the road issues, and that strategy has worked. I never owned an Intel Chip-set in personal equipment, opting to save money. I advocate it now, as commented.

I realize the prior revisions of Audacity are not supported. However, if the same issue remains, unless I upgrade to the latest Audacity over this, I may degrade back down. I have been a “hard core” ? advocate of Audacity in many a songwriters forums, and et alia as the way to go for the 1+1 demo recorder and to do “stuff” "manually. I’ve used possibly ? every other DAW out there, if, - could get it working (?) :slight_smile: I’ve worked back when tape was spliced and etc. So, I kind of like what I like and I do like Audacity.

I noticed one thing in the Upgrade here as fyi, - the Latency setting in the Config file did not (?) or may not have carried over. It only took a minute to reset it and did not actually record that, so I could be wrong. However, - did “wonder” why that may be different. I get inferences why, so, just fyi-ing.

I noticed a few things have been moved around and is throwing off my click-muscle-memory :slight_smile: otherwise, and why I may degrade back down.

I liked the prior interface, it was fine and the depth perception of the Menu Items worked for me. The new, well, - great work otherwise, I guess. For me, “form follows function”, so the “coolness” ? thing does not influence me, - it can turn me away. Well, my opinions are meaningless so, I will stop there.

So, thank you, and I’ll leave it there. I don’t have the time, presently, to upgrade again, and etc., and possibly have Menu items and etc., getting me slowed down. The Fidelity, remains the same so, - I’m good otherwise. I remember a time where one could opt to keep the “old” format, GUI (e.g, Windows upgrades, kept, old windows desktop) even though “upgraded” otherwise. (I’d love that, but I see, I have not been paying attention to “upgrades” :slight_smile: )

Again, thank you!

That may have been because you were updating from such an old version. 1.x to 2.x was a big jump. Normally settings will carry over.

With the addition of new shortcuts over many years, there was a shortage of available key combinations available for custom shortcuts. Because of this, a few years ago it was decided to have two sets of shortcuts. The “standard” set would contain the most commonly used shortcuts, and the “Full” set would contain all of them. You may be discovering that some of your favourites have been moved to the “Full” set. You can enable the “Full” set in preferences. See: