Background noise and turning off external mic..

Can I record from the web/internet/firefox to Audacity without using external speakers?
It seems if I turn my laptop speakers off I cant record anything.
If I leave them on then I get background noise from the external mic. If I shut off the mic Audacity records nothing.
How can such an amazing program not record directly through the internal pc?

If it’s not possible can I connect a line from the headphone jack to the mic on my laptop and change some settings on Audacity to only record from the mic and not the external mic built into my laptop lid?

Thanks :slight_smile:
I’m using windows 7 on new HP laptop. I “think” I used the .exe to install Audacity. 2.0.0

If your sound card drivers have an option for recording “Stereo Mix” then you can do it that way. See here:

For now I just hooked the headphone jack to the mic in jack and set Audacity to Line IN. I will play with the pc later to see if I can get it to work according to the link you posted.

Thanks! :slight_smile:

OK, had it working now all of a sudden it doesnt like it and wont record. Wow is this time intensive. A lot of messing about for something that should be easy.

That cross thing works a lot better on Macs than it does on Windows laptops. The Macs with two connectors tend to have Stereo Line-In and Stereo Line-Out, compliments of each other.

Windows Laptops have Stereo Line-Out (Headphone), but most have Mono Mic-In set for very low level, delicate microphone signals, not powerful, robust Stereo Line-level signals. Windows laptops are designed for communications and conferencing, not entertainment and music.

The two aren’t complements of each other, but yours might work. Some do. Some laptops have the ability to switch one connection between stereo and mono. Consult your instructions.


geekgirl, if you wish to add or update information in your posts, please post the update as a new reply. If you jut edit a previous post we don’t know what you have updated or if you require more help or if the problem is resolved.

Ok, I’ve got it working. I disabled Integrated Microphone Array and then plug in a headphone so I dont have to hear the audio as I record.
If I turn down the volume then it turns down the recorded volume.