Background media bleeds into recording track - sometimes

I’ve been recording some tracks where the singer needs to hear background music. For some time this worked “right” on my computer, which is I could play the music in VLC player or something external to audacity, then the person could sing into a recording track with a combined mic/headphone, and the background music would not be recorded in the new audacity track. (Obviously, there would be no physical, audible music coming from the PC because the microphone/headset suppressed it.)

For some reason, this changed halfway through my last project and the first few recording tracks did not contain any “bleedthrough” music as played on VLC Player, then in the same session, the rest of them did. This is some setting I need to figure out! Any ideas where to work with this?

Did you try to record YouTube or internet music or shows right about the time it started working funny? The settings for internet recording are different from live recording. Make sure you are recording from your headset combo (an actual thing) and not a fake device like Stereo-Mix or What-U-Hear.

Is it a USB headset?

I’m not fond of those. You have to go through software packages and drivers to split off the microphone and headphones for music production. Anything could go wrong.

Strict isolation between headphone and microphone in a headset is not guaranteed either. Depending on how the boom is constructed you can have leakage between them.

Do a test recording where you turn your headphone volume down as close to the headphones as you can get. Is there a volume control on the cable? Did the leakage stay around?

You did restart the computer, right?