Automatically fading badly cut notes to remove clicks

Due to a variety of reasons, some related to my ignorance, others simply due to the project I’m dealing with, I have built up a cover of a song using very amateurisly sampled instruments. This cover was built up using the…somewhat ill-suited choice of Adobe Premiere, by simply altering the length of the sampled notes, and placing them next to each other on the timeline to create music.

This has caused the final output to be a unpleasant symphony of clicks, due to almost every wave being cut out without proper fades. There’s no way I’m aware of to deal with the situation in Premiere, so I turn to Audacity to save me!

The only way I personally know of resolving the situation is going through every note in the project, and manually fading it right at the end. Towards this end, I have split every “instrument line” from premiere into two lines, alternating notes between the two lines then imported them all into audacity, in the hopes that if nothing else, it will make this manual fading involve less searching through lines for the clicks. Now, I have around 14 lines of notes, in which every note is surrounded by silence. In theory, it’s easy for me to go through each one repeatedly fading the very end, but for several thousand notes, I’d rather find a better way.

I feel like there must be a way to do this automatically. Is it possible? If so, how?

In case it’s relevant, I’m running Audacity 2.0.5 on Windows 7. Thanks.

There’s a way that you can make it quicker.
Download this “Fade In and Out” plug-in:
Instructions for installing:

Select one note, apply the effect with appropriate settings.
Select the next note and press Ctrl+R (repeat last effect)
Select the next note and press Ctrl+R … and so on.

If the notes are separated by empty track space (each note a separate audio clip) you can select a note by double clicking on it.

That’s really helpful, thanks. I was semi-hopeful for a one-click-sorts all approach, but eh, you can’t win them all. This way will save me a good deal of time selecting the ends of each note, at any rate. That’ll add up to some serious gains by the end. I’ll still get RSI, but… :slight_smile:

Thanks again.

If the notes are “surrounded by silence” then a gate will fade all the notes in one go, (e.g. Ggate) . You’ll have to reverse the track , then apply Ggate , then reverse the track back so it’s the right way around.
![Ggate free gate plugin).gif|462x283

If the notes are not surrounded by silence the easiest solution is software with automatic de-click , like Brian Davies de-click [ IIRC 21 day free-trial ].

So I downloaded GGate, and it seems to run fine, as in your screenshot. I reversed the track which again is fine. When I select individual notes and apply the noise gate, the plugin works as I expected - I see the change reflected in the wave. However, it’s not working when I simply run it on the whole project.

I have tried running it with the audio split into notes via Edit → Clip Boundaries → Detach at Silences, and without any split at all, but it seems to leave individual notes unaffected.

Here’s a section of one line after I’ve run Detach at Silences:

What I’m doing is simply selecting all, or nothing (select all seems to be auto-applied on entering the GGate popup when I initially have nothing selected) and then running GGate.

Have I got the wrong idea here?

Thanks for the help.

the silent interval between of some of the notes on your example is as short as 0.15 sec ,
that’s not long enough for Ggate to register that silence has occurred to detect the beginning of each note.

Here’s a workaround: slow down the track, say by a factor of 4*, apply Ggate which now has more time to operate and hopefully will detect and fade each note, then speed the track back up to the original speed.

  • If your track has a sample rate of 44100Hz , if you playback at 11025Hz the speed is reduced to a 1/4 , the duration of the silences between notes is quadrupled giving Ggate more time to act …
    change playback rate to slow track by a factor of four.gif

Did some more fiddling with the settings after your guidance, and things seem to be working brilliantly.

You’ve saved me a tonne of painful repetitive clicking, thanks a bunch!

Why is it necessary to reverse the track to apply the GGate?


The brief was to fade-out the end of the notes. Without the reversal Ggate would only fade-in the start of the notes.