Auto add extension on export

I think I screwed something up. Previously when exporting to a format, I recall Audacity automatically adding the appropriate file extension. I was having trouble with a certain file and decided to try exporting to a different format. Since then, I am having to manually add the extension upon export. I didn’t think I changed any of the basic settings but I must have. Anyone got direction for me as to where to go to fix this?

Some exports don’t have any idea what you want ahead of time. If you export WAV Microsoft signed 16-bit PCM, it should always add the .wav extension. I think there is another way to export WAV that doesn’t.


Don’t use dots “.” in the file name.

Presently, I am exporting to .M4A. I think that is the same setting I used previously but now it is not adding the extension. Is there another export which gives me the same file format but automatically includes the extension?

That may be the issue, but often the original files I am working with have dots “.” in the file name. Can’t recall if that was the case in the past or note. I’ll keep an eye on that, though.

If the file name includes dots then you have to add the extension yourself. See here .

There could be a checkbox to force the appropriate default extension to be added even if the file name has dots. We may do that at some future time.


That would be a nice convenience.