.aup to .wav track messed up on audio CD

I hope this is the right place to post this. I’m new here and just made an account hoping someone can help me. I’m at my wits end! I’m making an audio CD of myself playing the piano for a Christmas present for family. I saved my recording as .aup files in Audacity and edited them later. Then I exported them as .wav and burned them onto a CD. The first 6 tracks play beautifully. Half-way into track 7, though, the audio distorts and then the CD stops altogether. Tracks 8-12 don’t play at all after that, even going to them individually. I have to go backwards on the CD to track 13, and then tracks 13-16 play just fine. I opened up the .aup on Track 7 where the CD cuts out and this is what it looks like:

The red arrow marks where the track stops on the CD, and then why the heck is the audio line so wavy? The audio line is pretty straight before and after that part. Is that the problem? If so what caused that? The music sounds fine on the computer, and the CD plays fine on the computer. It only stops in CD players.

What the heck is going on?? Ugh I’m so frustrated, does anyone know what’s going on? Am I going to have to re-record all the tracks that don’t work?

What kind of computer, which OS, which Audacity? Each piece gets us closer.

Question Format

I really need to write the PC version of this, but you get the idea.

This is why there are individual forums for the different computers and different versions of Audacity.


The wavy line is probably because your microphone is picking up some low frequency vibration (you are recording with a microphone?) Do you live near a train station, above a subway, in an area subject to volcanic activity, were you tapping your foot on the microphone stand? If you have an electric piano plugged directly into your computer then it could be that the piano has started to produce some sub-sonic ripples. In either case I do not think that this is the cause of the CD problem.

Audio CD players and computer CD drives access data in slightly different ways. If the burned CD is of marginal quality then it is quite likely that some devices will be able to read the data but another device can not. Try burning another copy of the CD, preferably on a different brand of CD-R. Ensure that you are burning to a CD-R and not a CD-RW (CD players often do not like CD-RW’s). Burning CD’s at a speed lower than the maximum burn speed will sometimes improve the burn quality.

If you want to remove that wiggle, try using a Highpass filter set to 24 dB per octave 60Hz cut-off. A suitable high pass filter is included in Audacity 1.3.6. If you are using Audacity 1.2.6 and you don’t have a high pass filter, you can achieve the same effect by using the Nyquist prompt and entering this code:

(if (arrayp s)
(vector (highpass8 (aref s 0) 60)
(highpass8 (aref s 1) 60))
(highpass8 s 60))

Note that the filter can sometimes cause some peaks in the recording to go higher, so make sure that the highest peaks in your recording are below full-scale before you apply the effect.

Sorry, I didn’t realize, like I said I’m new :blush:

Ok, Audacity version 1.2.2, on an HP Pavilion zv6000 laptop (AMD Athlon 64 3200+ 2.0 GHz processor, 8x Dual Layer DVD+RW drive), Windows XP 2002 home.

Also, here is a list of the things I’ve tried:

    1. Burning a new CD (result = no change)
  1. Taking off track number 7 and burning a CD with the rest of the songs (result = CD plays up to track number 8 and no other track works after that)
  2. Burning the CD with a different burning program (result = no change)
  3. Burning the CD with a different brand of CD-R (result = no change)
  4. Editing track number 7 and removing the really wavy part and burning a new CD (result = no change)
  5. Exporting track number 7’s .aup file to .mp3 (with audacity), and then converting the .mp3 to .wav with a separate program (not audacity) and burning a new CD (result = no change)

I think that’s all I’ve tried so far…

Yes, I was recording with a microphone hanging next to the back of my upright piano (no keyboard). No, I don’t live near a train station or anything noisy like that, but there is a dog in the upstairs apartment that lives in the room above where my piano is, so maybe she made some noise above me or something.

Yeah, I tried burning a new copy using a different brand of CD-R (see my other reply above this one for things I’ve tried)–I used a CD-R both times.

I’ll leave this topic in this section of the forum as it is almost certainly not an Audacity issue.

You have certainly been trying, and this is a weird problem.
Let’s cover a few basics first;
CD’s must use audio that is in the format “16 bit stereo 44100Hz PCM WAV”
CD’s are limited to 99 tracks (no problem here :wink: )
There should be a 2 second pause between tracks (for strict Red Book compliance, but it is extremely common for CD’s to not have this pause and I have never ever seen this cause a problem)
CD-R’s must be used and they must be recorded in “audio CD” format rather than as a “data” disk.
Total capacity should not exceed 74 minutes. (greater capacity is possible with some CD’s but can cause compatibility problems).

I’m assuming that all of the above have been checked already.

Now if all the tracks (in WAV format) play correctly on the computer, and they are all in 44100Hz 16bit stereo PCM WAV format, then we can probably rule out the audio files being the culprit.
You can check the file formats by right clicking on the files and selecting “file properties” - on one of the tabs it will tell you what the audio format is - I think it is on the last tab in the “Advanced” section).

It seems that it is unlikely to be the CD’s as you have tried different ones and are having the same problem.

What we seem to be left with are:
The CD player,
The CD writer,
The CD burning software.

Does your CD player play other CD-R disks correctly?
Does your new CD-R play correctly on other CD players?
What CD burning software are you using?
How many tracks are there on your new CD? 16 tracks?

Try ripping a good quality commercial CD (If you do not have a CD ripping program, “Exact Audio Copy” and “C-Dex” are free Windows programs that will do this). Choose a CD that is free of scratches and has a similar number of tracks to your Christmas CD. Then burn a copy of that CD in the same way that you have been trying to make your CD. Does this copy play on your CD player?

Do you have access to another computer? If so, try burning your Christmas CD on that.

By the way, Audacity 1.2.2 is ancient (obsolete). When this current CD problem has been resolved you should give Audacity 1.3.6 a go.

You do not need to remove Audacity 1.2.2 as you can have both versions on your computer at the same time.

Audacity 1.3.x can open projects made in Audacity 1.2.x, but after saving a project in 1.3.x it will not be possible to open it in 1.2.x.

You can only run one version at a time, not both versions simultaneously. In fact it is generally advisable to only have one instance of Audacity open at a time, whichever version you are using.

Audacity 1.3.6 has a couple of minor bugs, but has very many improvements over 1.2.2 and is certainly worth looking at. Version 1.4 is due to be released fairly soon - it will be based on Audacity 1.3.x, and we are all looking forward to its release, so that is something to look out for.

Thank you, stevethefiddle! I definitely appreciate your time and response! :slight_smile:

The properties of my .wav files are:

Bit Rate: 1536kbps
Audio sample size: 16 bit
Channels: 2 (Stereo)
Audio sample rate: 48 kHz (I’m assuming that 48 kHz is different than 44100Hz? Sorry, I’m new at this :blush:)
Audio format: PCM

The settings to export .wav in my audacity program are definitely set to: 44100Hz 16bit stereo PCM WAV.
Yes, only 16 tracks.
There are 3 seconds of silence on both ends of each track (is that what you mean by a 2 second pause between tracks?)
I’m definitely recording for audio CD’s, not data disks.
I have 50 minutes of music

(For questions 1 and 2) I have used 3 different CD players to play my disk, and they all cut out at the same spot on track # 7. The first 2 CD players have had some trouble with a few home-made disks in the past, but for the most part play just fine. The 3rd CD player I tried I’ve never had a problem with before with any CD.

I used Record Now! for the first few burns, than I switched to Real Player’s audio CD burn program. The CD still failed at the same spot.
And, yes, 16 tracks.

So that leaves me with trying another computer. This was actually going to be the next thing I tried when my boyfriend got home from work this morning with his laptop. So, I’ll try that next and update with how it goes.

Also, now that I know there’s a new version of Audacity, if the burn on the other laptop doesn’t work, I’m going to also try re-exporting my .wav files with the new Audacity version.

Thank you again! I’m just freaking out because this is due today for a present >.< …but I resorted to a back-up present in case this all doesn’t work, so I’m not quite as desperate as I was last night. I’m still disappointed, though, because I’ve put about 40 hours of work into this >.<

Yes, 48kHz is different. 48kHz (48000 Hz) is commonly used in video and professional audio but not on audio CD’s. Audio CD’s must be 41000Hz (44.1 kHz).

Some CD burning programs will automatically convert the audio to the correct format, but this is not necessarily the case. This could be the cause of the problem.

Are all of the WAV files 48kHz or just some of them?

I’ve not got a copy of Audacity 1.2.2 but in both version 1.2.6 and all of the 1.3.x versions there is a little box in the lower left corner that says “Project Rate”. The number that is set here will override any other settings and when you Export your WAV file, this is the sample rate that will be used.
When you are making audio CD’s you should check that that box is set to 44100 before you export.

Good luck - I’m crossing my fingers and it’s not Christmas yet. :wink:

Arg I thought that was it! I went through and half of my songs were set to 48kHz instead of 44100Hz because of the Project Rate button. So I went through all of them and re-exported them at 44100Hz and double-checked all the file properties afterward. I burned the CD and the CD still stops at the same point on track number 7! Ugh!.. BUT there is a change elsewhere. Now only tracks 8 and 9 don’t play at all instead of tracks 8-12 not playing. And track 10 plays, but distorts and skips every 5 seconds and then eventually skips back to the beginning of the song and then ultimately skips over to track 11 in the middle of the song.

Because I recorded the songs with my mic while the Project Button was set to 48kHz, does that mean it’s a permanent setting for that recording, or does that only matter when I go to export the file?

Also, the funny thing is that some of the songs that were set to 48kHz played fine on the original CD, and some of the songs set to 44100Hz were among the tracks 8-12 that originally didn’t play.

I’m going to attempt to burn it on my boyfriends laptop now.

Your CD burning software must be capable of converting them to 44100 Hz on the fly.
It is still best to Export as 44100Hz if you know that you are going to burn them to CD as this means that your CD burning software does not have to do it (for reliability it’s best to keep the demands on your computer reasonably low while you are burning CD’s).

Each track in an Audacity project can have it’s own sample rate and bit depth.
In Audacity 1.2.x you need to take care when copying audio from one track to another that both tracks have the same sample rate. If you move some audio from one track to a track which has a different sample rate, then it will play at the wrong speed and pitch. This is not so much of an issue in Audacity 1.3.x as Audacity can now convert the audio to match the sample rate of the track into which it is being pasted.

Higher sample rates allow higher frequencies to be stored. The absolute theoretical maximum frequency that can be represented in digital audio is half of the sample rate. In practice it is a little less. 44100Hz is used on CDs and allows them a maximum frequency response of up to 20kHz. With 48kHz sample rates, the frequency response goes a bit higher, and the response above 17kHz is more accurate than when using a 44.1 kHz sample rate (that is why it is often used in professional audio).

For high quality recordings you should not go below 44100Hz as your sample rate. As the sample rate goes lower, the sound will become dull and loose its sparkle.

When it comes to Exporting, it is the project rate that is set at the time of exporting that is important.

In Audacity you can have the best of both worlds - you can record and edit at 32 bit 48kHz for very high quality, then Export at 16 bit 44100Hz for compatibility. This is common practice in studios.

Note that above 48kHz there is insignificant improvement in sound quality - it just makes the files bigger.
Recording at 32 bit (the bit depth setting) offers slightly better quality than 16 bit, but all the files are twice the size of 16 bit files. The difference is unlikely to be noticeable unless you are doing a great deal of processing.

The best choices for high quality recording are either 16 or 32 bit and 44.1kHz or 48 kHz.
For compatibility, the best choice for exporting is 16 bit 44.1 kHz.
If you don’t want to have to remember to change the project rate, just do everything in 16 bit 44100Hz.

Regarding the CD problem:
My suspicions are now lying firmly with the CD drive in your computer.

If the CD burns properly on another computer, then try as an experiment copying a known good CD on your computer. If this causes the same problem, then you probably need a new CD drive. Fortunately CD/DVD writers are pretty cheap these days. Unfortunately it is probably too late for Santa to bring you one.

Oh my God, it freaking worked!!!

I burned it on my boyfriend’s laptop and it worked!!!

All the tracks play beautifully now all the way through!!! ^^ ^^ ^^ ^^


Thankyouthankyouthankyouthankyouthankyouthankyouthankyou, stevethefiddle!!!

Oh my goodness, it helped SO much to have you helping me eliminate potential causes little-by-little. That was so incredibly helpful! Since I don’t use Audacity that often I didn’t have the faintest clue what was wrong or what could’ve potentially been wrong. I feel silly that it was ultimately my CD burner messing up, but I’d rather have that than to have to re-record a bunch of tracks! >.<

breathes a huge sigh of relief And not only that, but it’s finished in time to have for my Christmas present! ^^ ^^ ^^ ^^ ^^ ^^

Merry Christmas, stevethefiddle! Thank you so much again!! :slight_smile:

PS. Thank you, also, for your information about sample rates. That was extremely helpful and something I didn’t know before.

I bet you’re asking yourself if the standard for music CDs is 44100, why use 48000? I don’t use anything else. That’s the television sound standard. I’ve never met a CD burner program that couldn’t handle it directly–even some of the older PC programs.