.aup opens with no error but, not audio tracks appear

Audacity 2.4.2
Mac OS 10.15.7 (Mavericks)


long time user, never before experienced the following.

While I can open the following file (no Error msg), no audio tracks appear.

saved as:
thankfully p3_data
thankfully p3.aup

All data and “au” files appear to be intact within the eff > d1f folder, i.e. I can see them [au files] with the appropriate extension, HOWEVER, when opening within Audacity the .aup file (as mentioned) is blank, no audio/sound appear.

Since I cannot open the .aup as normal, I’ve tried:

  1. opening the .au tracks (individually or all together):


and while the above does work, i.e. shows the audio content and I can hear them, don’t know how to sync and/or pair up the respective, individual left/right channel of the original recording if even possible?

  1. making a copy and renaming the original .aup and _data title, i.e. “test_data” and “test.aup” and again, same results with no tracks appearing?

Two other recordings, separate files all done at the same time as the third and problem file above, open fine.

Any suggestion on how to open the .aup with everything as normal, or, as a default, how to pair up/sync the original .au files so I can do a work-around?

Completely “blank”, or tracks containing silence?
Which version of Audacity was the project created with?

yes, completely silent, v 2.4.2 - thanks.

Please attach the .AUP file to your reply - it may provide some insight into what went wrong.
See here for how to attach a file to a forum post: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1

For clarification, and as previously mentioned, the “_data” file opens with audio files (“au”) as was originally recorded and is accessible from the subfolders > “eff” > “d1f” The .aup opens as a blank, no wave patterns and thus, will leave to your evaluation as to how this will provide helpful information but have attached per your request
test.aup (500 Bytes)
. I tried also to attach the _data folder with sub-folders but the system will not recognize these so I’ve attached only two of the individual files, just in case these prove helpful as well.
eff1f0a8.au (1.02 MB)
eff1f0ab.au (1.02 MB)

That looks like a perfectly formed empty project.
Are you certain that you “saved” before closing Audacity?

yes, at the 99% level, the days of ‘not saving’ are pretty much exclusively in the rear view mirror … but to your question, would the ‘.au’ files all be visible from within the respective sub-folders in _data, had the recording not been saved?

'll place in the ‘mystery’ file as I’ve moved on (re-recorded) and thus, unless you have any additional suggestions that might help users, you probably have bigger fires to extinguish.

thank you for the support !

They could be in certain circumstances, for example, if the computer shut down while the project was open.

and if not, i.e. computer never shut down?

Normally Audacity will clean up after itself and delete any unused .au files. Of course that won’t happen if Audacity crashes, of if the computer loses power, or the computer is shut down. I can’t think of many situations where you could end up with a .aup that does not list any .au files and still have .au files in the project’s data folder. :confused:

There’s no bug that I’m aware of that could cause that to happen, and as Audacity 2.4.2 has been around for over a year, I’d have expected many other reports of the problem if it was a bug.

yes, one time only would not lean towards a bug without any other repeat of the same issue … moving on …

If you ever work out what went wrong, please do let us know.

(OS 11.2.3 AND Audacity v2.4.2)

This is a similar issue (I believe) as reported here originally, however, rather than NO audio or any other graphic appearing when opening, there is a ‘flat line’ appearing where all my tracks were.

In the last month (most recently today) opened a project I was editing and all flat lines appear whereas yesterday (when last opening) all were showing as valid sound waves. Same issue happened about two-weeks ago and has occasionally occurred in the past. No one seems to know what the cause or what remedy to apply - I have read other users having the same issue.

These projects were ‘copied’ conversions from the original recording within Audacity, exported to .wav files then the .wav imported into Audacity, then saved as an Audacity project where edits are performed. I’ve used this same workflow for hundreds of projects over the years and fortunately, this issue has only occurred perhaps, 5 - 6x (including the two, most recent). However, since I cannot recapture these edited files (yes, 30-40 hours involved per each project) my only recourse is to open the original file and begin the process again.

There was a ‘warning’ prompt appearing when opening but I didn’t screenshot AND, since I’ve also experienced this before, when seeing the flat lines, I knew there was nothing I could do to recover what was lost.

This is a common issue in all versions of Audacity prior to 3.x in the following scenario:
The project’s “_data” folder is missing, or has the wrong name, or is empty, or is in the wrong place, or cannot be read.

The problem becomes permanent (unfixable) if you select the “replace missing blocks with silence” option(3rd option) in the warning screen.

This scenario was the motivation for the new single file AUP3 format in the Audacity 3.x series.
The current version of Audacity is 3.0.2, and Audacity 3.0.3 is scheduled for release very soon. It may be worth waiting for 3.0.3 because it contains some important bug fixes.

thank you … now (until the next version) I will always export a .wav file of the most most recent edited project … although all tracks will collapse to one initial stereo file, I can use this to continue the project rather than starting all over again.

That’s a very good idea.
When you are recording, it’s a good idea to export the recording as a WAV file immediately after you stop the recording so that you have a backup of the raw recording. If anything goes wrong later, then at least you won’t need to re-record.

On the first page of the Audacity 2.4.2 user manual (“Help menu > Manual”) there’s a section called “Managing Audacity Projects”. That gives a detailed description of Audacity projects, and lots of tips about how to manage them safely.

You can always use Export Multiple to export each track as a separate WAV file - ensure you have the option in Import/Export preferences such that leading silence is not ignored (default setting) - otherwis all tracks will start at T=0 on import.


yes, a very good suggestion - will save much time from recreating from scratch. Also hoping the next version (as mentioned earlier) will negate or certainly reduce this issue (flat lining) from returning.

thank you …