AUP File corrupted on save

Hi, I am new to this forum but have been using Audacity to record live sets for 2 x Years on and off without any real issues.
I recorded a set last Monday and something has gone horribly wrong… I was hoping there would be a fix (and if there is I will be eternally grateful) but I also want to know what has happened.

The computer is a new build and a lot faster than my old one but still running XP at the moment. I reinstalled an existing copy of Audacity 2.0.5 (along with Lame etc) from a memory stick of sound progs that I keep and everything seemed to fire up fine.
I use a Traktor Audio 6 as a sound card and I set Audacity to record at 44.1k 24bit, I discovered previously that when I start Audacity it sets the Traktor to output at 48k (even though Audacity is set at 44.1) so I always go back into Traktor setup and put it back to 44.1).
I recorded 13.5hrs of live set and the waveform on Audacity was fine. At the end I hit stop and then save as Audacity Project intending to convert it to MP3 when I got home (after 13.5hrs you don’t want to hang around waiting for it to do the conversion there and then).
When I looked at the saved project it had shrunk to 50mins and although there is audio there it’s like listening to a tape on fast forward…

I have tried various file recovery programs hoping to find the missing blocks in the temp file but there is nothing there. Is there a magic bullet that can find the data at low level?
I’m also not convinced that it is recoverable as the block files in the data folder are timed at just under 2mins apart and are only 781kb in size where normally they are around 6sec apart and over 1Mb each.

Has anyone come across this before? Maybe I set something wrong as it’s a while since I last used it :frowning:


13.5 hours is the cutoff, I think. Or some number in there. Audacity would have “started over” and flushed the old show. I think 13.5 is based on 16-bit and it’s earlier if you’re using a higher bit depth. Someone will correct me.

Audacity is not a surveillance program.

It’s possible that limit no longer exists, but that would be in Audacity 2.1.0, not an earlier version.


And you are warned not to put a Windows XP machine on-line.


Hi Koz,

It’s not surveillance, it’s dance music :slight_smile:

Not sure what you mean by not putting an XP machine on line??? It’s a stand alone machine with a fast SATA internal drive.


Thinking about the re-start scenario, if it had re-started it wouldn’t explain the 2min block spacing and the smaller block size, I would have ended up with the last hr or so???


He means that now that XP has been abandoned by Microsoft, it is no longer updated to fix security vulnerabilities, so not recommended in situations where it may be vulnerable to attack (such as being connected to the Internet). XP can still be useful as a standalone machine, but sadly its days are numbered.

The current version of Audacity is 2.1.0.

Note the minimum system requirements for the current version of Audacity:
Windows XP (64- or 32-bit)
64-bit (x64) requires XP Service Pack 2. 512 MB/1 GHz
32-bit (x86) requires XP Service Pack 3. 128 MB/300 MHz

Audacity 2.0.5 has a project size limitation of 2^31 samples, beyond which it could not open projects correctly. By almost uncanny coincidence, that’s just over 13.5 hours at 44100 Hz sample rate. The problem is fixed in the current version of Audacity.

The current version of Audacity is available here:

Note also that the maximum size for a standard WAV file is 4 GB.

The block files would indeed be that size if you recorded at 24-bit depth.

The blocks would be a long time apart if you recorded at a ridiculously low sample rate - might you have made a mistake typing in the project rate or something like that?

The 32-bit limit of 2^31 samples amounts to just over 13.5 hours at 44100 Hz - I think it is a per track limit, not a project limit, so two tracks at 10 hours is not a problem. If you had gone over the limit, what should happen is that the entire project is silenced with orphan block file errors. So I am guessing you did not go over the limit.

Do you see error messages when opening the project? Can you post the contents of Help > Show Log… after opening it?

What does the Hz say above the Mute/Solo button on the track? You might want to click the track name, choose Set Rate then choose a much lower rate. That will extend the track and slow it down.


Hi Gale, thanks for your suggestions.

I was away over the weekend but tried opening the project from memory stick (on my laptop) and it opened without errors but still 50min long.
Sample rate is shown at 44.1 (as recorded) and if I change the sample rate to try and get the correct length it plays as sound bites (chopped up) and unintelligible.

Before I went I had loaded the AU files back into Audacity temp folder and sure enough, when I started Audacity again on my home computer it said I had a recoverable project. This did show errors:

23:48:10: Audacity 2.0.5
23:48:12: Trying to load FFmpeg libraries...
23:48:12: Trying to load FFmpeg libraries from default path, 'C:\Program Files\Ffmpeg For Audacity\avformat-52.dll'.
23:48:12: Looking up PATH environment variable...
23:48:12: PATH = 'C:\ProgramData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Common Files\Lenovo;C:\Program Files\Lenovo\Client Security Solution;C:\Program Files\Toshiba\Bluetooth Toshiba Stack\sys\;C:\Program Files\OpenVPN\bin'
23:48:12: Checking that 'C:\Program Files\Ffmpeg For Audacity' is in PATH...
23:48:12: Warning: FFmpeg directory is not in PATH.
23:48:12: Temporarily appending ';C:\Program Files\Ffmpeg For Audacity' to PATH...
23:48:12: Checking for monolithic avformat from 'C:\Program Files\Ffmpeg For Audacity\avformat-52.dll'.
23:48:12: Error: Couldn't find symbol 'avutil_version' in a dynamic library (error 127: the specified procedure could not be found.)
23:48:12: avformat not monolithic
23:48:12: Loading avutil from 'C:\Program Files\Ffmpeg For Audacity\avutil-50.dll'.
23:48:12: Loading avcodec from 'C:\Program Files\Ffmpeg For Audacity\avcodec-52.dll'.
23:48:13: Loading avformat from 'C:\Program Files\Ffmpeg For Audacity\avformat-52.dll'.
23:48:13: Returning PATH to previous setting...
23:48:13: Actual avutil path C:\Program Files\Ffmpeg For Audacity\avutil-50.dll
23:48:13: Actual avcodec path C:\Program Files\Ffmpeg For Audacity\avcodec-52.dll
23:48:13: Actual avformat path C:\Program Files\Ffmpeg For Audacity\avformat-52.dll
23:48:13: Importing symbols...
23:48:13: All symbols loaded successfully. Initializing the library.
23:48:13: Retrieving FFmpeg library version numbers:
23:48:13:    AVCodec version 0x344802 - 52.72.2 (built against 0x344802 - 52.72.2)
23:48:13:    AVFormat version 0x344002 - 52.64.2 (built against 0x344002 - 52.64.2)
23:48:13:    AVUtil version 0x320f01 - 50.15.1 (built against 0x320f01 - 50.15.1)
23:48:13: FFmpeg libraries loaded successfully.
23:49:04: Warning: Orphan block file: 'C:\My MP3 Terrace\25 May Opening_data\e00\d00\'
23:49:04: Warning: Orphan block file: 'C:\My MP3 Terrace\25 May Opening_data\e00\d00\'
23:49:04: Warning: Orphan block file: 'C:\My MP3 Terrace\25 May Opening_data\e00\d00\'
23:49:04: Warning: Orphan block file: 'C:\My MP3 Terrace\25 May Opening_data\e00\d00\'
23:49:04: Warning: Orphan block file: 'C:\My MP3 Terrace\25 May Opening_data\e00\d00\'
This continues for many files... It ends:
23:49:04: Warning: Orphan block file: 'C:\My MP3 Terrace\25 May Opening_data\e00\d03\'
23:49:04: Warning: Orphan block file: 'C:\My MP3 Terrace\25 May Opening_data\e00\d03\'
23:49:04: Warning:    Project check ignored orphan block file(s). They will be deleted when project is saved.
23:49:04: Warning: Project check found file inconsistencies inspecting the loaded project data.

The time stamp on the first AU file is 17:00 and the last is 06:34 = 13hrs 34mins


The track info above Mute/Solo won’t say “44.1”. Does it say 44100 Hz or something else?

OK, you’re over the limit at 44100 Hz which is 13 hours, 31 minutes, 35 seconds and 34148 samples.

So, perhaps being only just slightly over the limit, not absolutely all the files are orphaned.

I suggest creating a new folder (for example, on your Desktop), then in Explorer, right-click over “C:\My MP3 Terrace\25 May Opening.aup” and “C:\My MP3 Terrace\25 May Opening_data” and choose “Copy”. Paste into the folder you created on your Desktop. This is to create a backup.

Then obtain Audacity 2.1.0 from and open “C:\My MP3 Terrace\25 May Opening.aup” in 2.1.0. With luck, if there are no other issues with the project, it should open correctly.

If it doesn’t open correctly, then it’s a case of following Recovering crashes manually - Audacity Manual. If opening the project in 2.1.0 did anything to mess up the data, recover from the backup.