aup-3 files are empty when they are opened

Hello, i’ve got a problem with audacity:

  • I created an *.aup-file with Audacity 2.x.
  • I opened Audacity 3.02, edited the file and saved it as *.aup3.
  • This worked with different file sizes (400 MB to 2 GB) until July 13th.
  • I merged two aup-files of 630 MB (mono file) and 2.6 GB (stereo file) into one aup3 file of 3.9 GB (stereo file) on July 14th.
  • Then i saved the file and closed Audacity.
  • If I open the file now, the window is empty and the file has only 320 KB.
  • New tries with the same aup-files failed.
  • Other files I created in these days were empty too.

Versions: Audacity 3.02 macOS Big Sur Ver. 11.4

Are you saying that you failed to reproduce the problem or that the .aup3 file failed to save or failed to save properly?

Are all .aup3 files you create broken?

If you have a consistent way to create a “broken” .aup3 file, please post the files and give us the steps to recreate the issue. Does it also fail with Audacity 3.0.3 RC03: Release Audacity 3.0.3 RC3 · audacity/audacity · GitHub

I can reproduce the problem. If i save the project, there’s a new window called “Compile Project” wich wasn’t there before. If this window comes, all files i open are empty.

Screenshot 10:32:11 When i open this 3 files, they are okay and not empty.
Screenshot 10:41:33 Then i opened “Mandela Konzert Teil 1” and “Mandela Konzert Teil 2” and copied “Teil 1” into “Teil 2”. You see the result in “Screenshot 10:47:48”. Then saved in file you see in “Screenshot 10:48:55”; 3,89 GB. When i save the project, there’s a new window called “Compile Project” wich wasn’t there before.
Screenshot 10:49:47 This Screenshot shows the opened file wich is empty.
Screenshot 10:50:58 This Screenshot shows that the file has only 328 KB.

Every Audacity*aup3-file i open is empty now. See Screenshot 11:05:29 and Screenshot 11:08:20.

Best regards (934 KB)

  1. On this screen, for some reason you are zoomed way in. Can you zoom all the way out, or Ctrl-F = Fit project to width?

  2. .png files in MAXOSX folder are not readable for some reason.

  3. I have to run out for the day. I’ll should be back later today or tomorrow.

OK, so I am back…

I am confirming that none of the files in MAXOSX folder are readable, either by windows or by or by

I don’t see this in any of your screenshots. Any chance you can get a snapshot of this Compile Project screen ?

Exactly how are you saving your combined project file? For example, which keystrokes or menu items are you using?

Hi. I’m using Mac OS 13.13, High Sierra, and I had that problem: after saved some files (aup3), when I reopened, they look empty, and there is no horizontal bar for the window, all record tracks are empty!!, and if I exit Audacity at that moment, (without any question about saving the file) the size of file will be now 328 Kb.

What I just came to do is NOT exit in the normal way. In the apple menu I used Force Exit for Audacity, and then my aup3 file has it original size. After that, I reopen the file and it is perfect, exactly as I let it last time.

This is not a real solution, but is a way to NOT lOST hours of a job!!

I hope this will be useful for many people.!!

Sorry, I made a mistake: Mac OS 10.13, NOT 13.13.

Same here !
I lost all my records and all my editing !!! I’m so angry and disappointed. I don’t understand why.

OSX M1 Big Sur 11.5.2 (20G95)
Latest Audacity version (tried with 3,02 et 3,04) Same issue.

Help ! Cannot work anymore…

Fascinating. So Save an AUP3 project in the normal way and then tell the Mac to crash out of Audacity instead of letting it close normally preserves the show.

You’re right. You can’t do that constantly because it leaves trash around and you really should restart the Mac every time you do so it can clean itself up.

There is one other note from here.

“Screenshot 10:48:55”; 3,89 GB.

That’s dangerously close to the 4GB limit on many popular USB sticks. Suddenly turning up with a super tiny 328 Kb show could be the amount that the completed show exceeded 4GB. The addressing system runs out of steam at 4GB and starts the counter over again at 0KB.

It’s possible (I’m making all this up now) that causing Audacity to crash leaves the show under 4GB and working.


That sounds excatly like the problem I described here:

In my case, it only happens when I open a AUP3 project via the Cmd-O keyboard shortcut.

– How did you open your files?
– Did you try different (other) ways to open your project file like via Menu, drag AUP3 on App icon, double-click on AUP3-file?

I cannot reproduce this on W10 with 3.1.0 alpha audacity-win-3.1.0-alpha-20210831+6d3dd0c-64bit

Both projects open fine - no corruption that I can detect

Okay, we have identified the cause: On macOS, if you have your language set to something that doesn’t use a dot as the decimal point (but eg a comma instead) and you use cmd+o to open it, and when there’s no other project window open does this bug occur.

We also found a fix for it which we’re testing now, and once we made sure this fix works as expected, we’ll try to get this fix out to you ASAP.

Until then, the workarounds are

  • Don’t use cmd+o to open your projects (use drag’n’drop, opening the project from the finder, etc.), or
  • Set your Audacity language to English

Ok, I downloaded the new version, and it works fine. Thank you!