I’m using Windows 10. I have an Audiobox USB. I’m feeding my mic and guitar thru it. I can record and playback. But when I’m getting ready to record and I’m trying to test sound levels, I can’t monitor the levels. I.e. there’s no movement on the meter. Help?

I had the same problem. You must set the option playthrough in audacity. Then, to avoid letency,go in your pc setting/audio/device properties/additional properties/speakers/advanced/exclusive modalities and enable the two options. Sorry for my english, my win 10 is in Italian.

Ensure that in the “Device Toolbar” (Device Toolbar - Audacity Manual) the “host” is set to “MME” and the “Recording device” is set to the USB option.

No, you should not do that. That will cause the input sound to echo through to the output. Software playthrough may be used when recording from a USB turntable or cassette player, but is not suitable for live recording.