Audio-with-music podcast doesn't record

Windows XP with Firefox
logitech headset with USB connection
Audacity 2.0.3

I recorded an audio on audioacrobat.com over the phone and it came thru fine and was used in the podcast, where it also came thru fine.

The music which I used, an intro and a stinger, was something I bought online and it plays just fine on Audacity as I am playing it on the machine. It plays well together with the audio file on the machine. They both begin and end where they’re supposed to.

The problem comes in recording the two together and getting a final .mp3 file of the two together.

I played two podcasts without listening to the new file–the final recorded version–never realizing it had NO MUSIC on that final file. THE MUSIC HAD NEVER BEEN ADDED TO THE ALREADY-RECORDED AUDIO.

Last night, I realized my mistake. I then pushed the red RECORD button and then the PLAY button on one of the episodes. I thought that would fix it. But of course, I couldn’t tell until I listened to the final, new file after it was Exported. At the end of making the podcast file, it said it was bringing the two files together as a mono file. (They had been a mono audio and two stereo music files.)

So, I went to File Export and a dropdown menu came down and I put in some info and it exported to my computer. But, it HADN’T fixed it!!

There is an issue that may or may not affect it. In only one of those files did I click on “Save as . . .” to make a first Project for the file. (It is not clear in Audacity exactly when you should do it. It seems like it’s ok to do it at any time up to the end of the project. So I completely forgot it.) From that, I got an .au file, a data_file and an .mp3 file. For the second one, I got an .mp3 file and an .au file. I don’t see any data file.

SO WHAT DO YOU THINK THE ISSUE IS?? I MUST have this cleared up within the next couple of days!! My podcast series is WAY overdue!

PS: The ‘recording’ of the last audio with music is still in the Audacity machine. I would be willing to give you the PW,etc., if you want to look at it.

NewbieM

There is no need to save an Audacity project though it is preferable if you are going to leave the project window open unattended.

If you already have your music track and you already recorded your voice, what was the other track you were trying to record?

If you want to record while listening to existing audio you need Transport > Overdub to be checked.

If you have a mix of stereo and mono tracks, Audacity will mix to stereo (not mono).

If you can hear what you recorded when you play it afterwards, and you can hear the music track playing at the same time, then all you need to do is make sure no tracks are muted, then File > Export (not File > Export Selection). Also make sure the -…+ sliders on the tracks are not pushed to left, because that will silence the tracks.

If you didn’t actually record what you intended in any of the tracks, that’s what you need to address. Try looking in Device Toolbar and selecting the correct input.


Gale

Answers to your questions, Gale -

There were 3 tracks–two music tracks (two stereo files: an intro piece and an outro or ending piece) and an audio track (a mono: the piece in the middle).

Yes, Audacity said it was going to mix these 3 files to mono just before it exported them. THIS MAY BE A SIGN THAT THE 2 STEREO FILES (the music) NEVER RECORDED ONTO THE FINAL FILE. Thus, Audacity would only have a mono file to mix.

What are the “- . . . + sliders” on the tracks? Are these just plain sliders? What are the + and - signs for ?

  • One of the two music files WAS pushed up against the left wall. And it never played. The ending piece of music wasn’t. But, once I found out there was no music on the front end, I never listened to the back end to see if the final, short ending piece of music played.

YOU SAID THAT IF I WANT TO RECORD WHILE LISTENING, I NEEDED TO PUSH SOMETHING (I FORGOT THE ACTUAL DIRECTION; IT’S NOT ON THIS PAGE TO REFER TO). Did you mean that I can’t push both PLAY and RECORD at the same time?

Thanks.

Please do not shout in capital letters.

I am still very unclear what recording has got to do with this. If you already have the tracks on screen you do not need to record them again.

Make the Audacity window as large as you can. Hold ALT on your computer keyboard. While holding ALT, press PrtScr. Open Paint. Edit > Paste. Save the image as a PNG file. Attach the image to your reply. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1 .

That slider changes the volume of the track:




Try placing the knob centrally between the - and the + . If you push that slider to left, you will silence the tracks.

You cannot press Play and Record at the same time. You can play a previous track while recording a new one if you press Record (only) and Transport > Overdub (on/off) is checked (ticked).

But if you have already got the audio you want on the screen, it’s irrelevant. You do not need to record anything else, you want to export it. File > Export, as I said.


Gale

I am attaching the screenshot of 3 tracks of one episode of my podcast.

Re Input: I recorded the audio by phone via AudioAcrobat, but the two tracks of music were recorded probably in a studio by mike, I would imagine. Don’t know about that. But, since I didn’t record it on Audacity, I wasn’t sure what to click on. So, I clicked on the default program for Windows, which is Microsoft Sound Mapper - Input.

Previously, I had for input: a SoundMax digital audio CD player (It was just there. I hadn’t checked what was there before.)

Re Output: Same thing, default program for Windows is now MS Sound Mapper - Output.
Prior to this, I had SoundMax Digital Audio.

Input Channels: I now have selected Stereo. (before it was mono.) But I’m confused about this. I have one mono and two stereo tracks. What should I put for that?

Transport > overdub was checked when I looked at it now, although I had never checked it. The fact is, I didn’t need it because I wasn’t trying to record a track while playing another. What effect would that have if it was checked?

So, whatever I’ve done wrong has been wrong since the beginning podcast episode. I’ve done 4 so far. And all are silent. The music is good, as I said before. So is the audio podcast.

Question: Why is the third track grayed out on the label end? And the wave has a dark gray background, as well. That has happened to me before more than once. It happened one time when I was having a devil of a time getting a muted track unmuted. It just wouldn’t un-mute. At some point, I went to the Tracks section above the working wave area and selected ‘unmute all tracks.’ That’s the only thing that did it. Now, the track plays when I play it (but, of course, not when I put it together. The .mp3 that results only has my recorded audio on it, as I told you.)

So, I hope you can see something here that clears up this whole thing. I bet you can!



Thanks.
Audacity--MStock,Podcast9-25-13.PNG

I’m glad you kept mentioning that I didn’t need to re-record the tracks I already had there. I thought I needed to record them onto another .mp3 file! I had no idea that the mixing occurred on the File - Export (lol).

As before, I don’t know which track is supposed to be which or understand why you simply do not File > Export….

If you just take your computer mouse and press the green Play button then you should hear the second track, then the first track, then the fragment at the end of the third track. Does that sound as you want it?

If yes, then choose File > Export…. Do not choose > File Export Selection…. If you choose File > Export Selection, you will only export the selected track (the second one which has the grey shading in the blue waves). Do not mess with the toolbar that says MME and SoundMapper because that is only for setting up recording.

If it’s easier for you, leave the menus alone when you export. Hold CTRL on your keyboard. While holding CTRL, also hold SHIFT. While holding those two keys, press E. Now release all three keys. This does File > Export for you (of all tracks mixed together).

One other point. Tracks 2 and 3 are at 44100 Hz (good quality, containing all the frequencies that humans can hear). Your project rate bottom left is 11025 Hz. I suggest you change project rate to 44100 Hz. If you leave project rate at 11025 Hz you will make tracks 2 and 3 (and track 1 if it is also at 44100 Hz) sound “dull” because you will remove all their high frequencies. The MP3 file will not be any larger for choosing 44100 Hz.


Gale

Gale -

Success!! I am so grateful to you, words can’t express the extent of it.

When I sent the file back to AudioAcrobat, started playing it, and I first heard the music emanating from it–pure, clear and oh, so long-sought, tears welled up.

All I needed was someone like you telling me and showing me. The written directions just didn’t do it. Thank God for you.

Best,
Mary Stock (NewbieM)