Audio Tracks flatlined all of a sudden

I got up to cook dinner and when I sat back down to the computer, there were no waveforms in any of the tracks, they were all flat lines. No sound. As far as I know, I did nothing in the program between it working and not. The undo function doesn’t fix the problem, it changes back Splits and things I was doing, but as though I were working with flatline audio all along. I imported another wav file to see what would happen and that one does have a waveform and sound. Then I tried to ‘save project as’ to see if a previous save would work or reopening the application would help, but it will not allow me to ‘save as,’ not even on an external drive (message says perhaps either unwritable or not enough hard disk space). There definitely is enough space.

So has my project been corrupted? Can I use the recovery to try to get some of my work back? Any suggestions?

I’m using Mac High Sierra 10.13.3 and Audacity 2.2.2


Was the original audio imported from WAV files? Did you move the WAV files?

If the original project with the flat-lined audio is still open, please try Help > Diagnostics > Check Dependencies.

– Bill

Yeah, they’re all wav files. I did move one of them after I imported into the project, from a download folder to another one. But that shouldn’t matter should it? Looking at the Check Dependencies diagnostic shows that the project is self-contained. So moving the original files after importing shouldn’t affect the project since the files would’ve been copied during the importing, right? I haven’t messed with any of the files associated with the project folder, just the original of the one that was copied when I imported it.

Sometimes you can get punctuation marks to do that. Do you have dates in the filename? Today is 2018-03-29, not 3/29/18. Slashmarks can cause troubles. Upper, lower, numbers, -dash- and underscore are the only safe characters for filenames.


You can get Sudden Timeline Silence Syndrome if the system has trouble writing to the cache system. Every time you make an edit, Audacity has to save the whole world for when you need to UNDO. If it has any trouble reaching the drive system at all, that process will get very upset.

Are you connected to any cloud storage services? That and network connected drives can cause problems. Everybody wants you to believe they’re exactly like your normal drives…but they’re not. Just having the connection there even if you’re not using it can cause problems.


It depends on your settings in Import / Export Preferences.
However, if your preference is to “copy in”, and the project is reported as self-contained, then we have a mystery.
– Bill

Indeed, I’ve got the preferences set to ‘Copy uncompressed files into the project,’ and a dependency check that says ‘Your project is currently self-contained.’

Someone else is saying that a connection to a cloud drive or file name problems might be it. I don’t think those are the problems. No cloud in use, and no odd characters (only letters and spaces).

Any other suggestions? Tomorrow I’ll probably call it a loss and see if my previous save is intact. It’s really strange if the project just became spontaneously corrupted! Anyway, thanks for putting your thought into it.

Re-check that it is actually Audacity 2.2.2 that is running and not a previous version (“Audacity menu > About Audacity”).
If you upgraded to 2.2.2 from an earlier version, it may even be worth completely removing Audacity from your machine and doing a fresh install of 2.2.2, just in case macOS did something weird when updating.

No question it’s 2.2.2. Also, it’s a fresh install from just a couple weeks ago. No previous version of Audacity has been on this machine.

Are you the poster child for exporting a WAV safety copy of a show before you start to edit it?. In the face of computer insanity, you could go back to the original recordings and start over.

Do you routinely save changes on top of the old files? That’s a terrifically bad idea.

That’s not to say we know what’s going on. Lots of blank looks all around. But problems like this confirm the obsessive tricks people use when the client is writing you big checks for the work.


Yes, I’ve always wanted to be a poster child for something, oh good. Well, I rebooted the project from the last save, and it loaded just fine! With lots of orphan block files, which I assume is the unsaved work. Is there a way to make it recognize those orphan files or they’re toast and I may as well delete them?

But yes, I’ve been saving over the same project file every time. I guess it worked out this time because it didn’t ruin ALL the work, but I’ve learned my lesson about using extra caution, for freakin sure!

Thanks you all.

The orphan files cannot be re-integrated into the project. They may be left-overs in support of Undo.
Saving “over the same project” is fine as long as you are using 2.2.2.
– Bill

I rebooted the project from the last save

That’s not what I said. I said when you finish your recording, Export a WAV (Microsoft) perfect-quality, stand-alone sound file of the work. Then, to be completely obsessive, copy that file to a thumb drive or other drive system.

The idea is to split the work from Audacity influence. Just repeatedly saving Projects isn’t useful in this case. We don’t know that the Project system isn’t causing troubles.

I still have the WAV files from paid recordings I did years ago. This reflects another reality—a call from a Producer: “Say Koz, do you still have that recording you did two weeks ago?”

Of course.