Audio track problem

When I record I can hear what I am recording and then a second later an echo. Like there is a delay but I do her the original audio live

How do I get rid of the second audio signal??

Art Robin

Voice talent

If you are lucky enough to have fast system playthrough of your recording, then turn off Transport > Software Playthrough in Audacity to get rid of the echo.

Please state your version of Windows and version of Audacity if you need more help (see the pink panel at the top of this page).


Audacity > Edit > Preferences > Recording
The top section of that panel should only have one thing selected. Maybe no things. Try that.

An echo is usually the transition time for your voice to go through the computer and come back out. You can’t stop that, but you can turn off the pathway and see if that helps.

The overdubbing people run into this problem right away. Live monitoring is rough to do.