Audio skips during recording

Hello. I’m having some issues with audio skipping when recording. When I play it back, there are chunks of audio that are just totally skipped over during recording (around 1-6 seconds or so). I’m currently using Audacity v2.1.1 on Mac OSX 10.12.1. I’m using a 2014 15inch MBP with 16GB of RAM. I’m using it with a Behringer X1204USB and 3 dynamic microphones (2 are the ATR2100-USB and one is an old mic with the name Starpower SP-1 on it). I record a podcast on mono.

Up until a couple months ago, I was never having any issues. It seems that the issue become more prevalent when I introduced a third mic into the mix (the SP-1), but I’m not sure if that’s coincidental, as I did recently record an episode with just two mics that had some skipping (but not as much). At one point, I thought the issue may be that I had too many other programs running. However, during my last few recording sessions, I closed all programs except for Audacity and still ran into the same issues.

Let’s see (I’m looking for some other info that may be relevant): under Preferences > Quality, the Real-time Conversion is set to Medium Quality, and the High-quality conversion is set to Best Quality (and Shaped is selected under Dither). The Project Rate is 44100.

What could be causing these skipping issues, and what can I do to fix them? Any help is much appreciated.

See if you find anything in there. The Mac can’t tell the number if analog microphones plugged in, so that one is a false clue.

Do you have a Solid State Drive or spinning metal? Batteries or wall power?

Close the network connection. Either unplug the cable, or shut down the WiFi (click on the fan in the upper bar).

Also, newer OS-X systems have very serious power management and a thing called AppNap.


Thanks for the reply. I just went ahead and disabled AppNap to see if that helps. However, this was never an issue up until a few months ago. I’m going to try a few things off the list that you sent and see if that helps. I went ahead and disabled Software Playthrough.

I’m using an SSD drive. I mainly record while using wallpower.

I’ll test out recording with the network connection shut off.

Many people find changing the buffer setting helps. Don’t miss that one.


Thanks. I currently have it set at 100. Through some Googling, I find that most people use that buffer setting. Since I’m unfamiliar with this setting, is there a setting you could recommend for me to try?

No. That’s what’s so darn much fun about this. You change it until your problem goes away. Pay attention. If the problem gets much worse then you have your answer.

I always catch grief for this, but is your drive filling up? Audio (and video) production takes up room faster than you think it’s going to.


USB? Typo?

Handheld dynamic microphone with USB digital output and XLR analog output


On Mac, the general recommendation is to start it at 0. If that setting doesn’t start recording, move up in 10 millisecond increments until it starts recording smoothly. Don’t go above that setting when you find it.