Audio recording too fast - skipping effect

Hi, this is my first post so apologies if its in the wrong place or anything.

I am running Audacity 2.0.5 on OS X 10.10 Yosemite (2013 Retina Macbook Pro 13), installed from .dmg

I’ve just tried to record a mix with the master audio from my mixer running into an Akai EIE Pro Interface, which my laptop is recording on channels 1&2 Stereo. The issue I’m having is that after about 2 minutes of perfect audio, Audacity began to record too fast Audio Position was progressing faster than real time. The resulting recording was basically snippets of the actual input, skipping forward after each (kind of like a record skipping forward continuously). The actual output I was hearing whilst recording was fine - I mixed for about 40 minutes before checking it to find that all but the first 2 minutes of audio was completely corrupt, and the total recorded time was about 23 mins. I’ve tried to record three times since, using a lower sample rate, and have had the exact same results.

Anyone else experienced this? Any help appreciated.

The quick version of this is Audacity does not yet support Yosemite. Many odd things have been reported go wrong with this combination. I’ve been avoiding the upgrade until this is resolved.


Also make sure the sample rates are the same everywhere.

In particular, open Applications/Utilities/Audio MIDI Setup and set the AKAI input and output sample rate to the same as Audacity’s project rate.

Open Audacity > Preferences… and try increasing “Audio to buffer”.