Audio Pops During Playback

Hello everyone. I have been using Audacity for some time now on my MacBook Pro. Recently I upgraded my OS to El Capitan and my Motu UltraLitemk3 Audio Interface (via USB2) failed to work. Motu states that my model is not compatible with El Capitan yet and they are working on new firmware but they also stated using FireWire would solve the problem. I purchased the FireWire to Thunderbolt adapter and connected my Motu and it works fine with iTunes, QuickTime Player, Ableton Live 9, SoundCloud, etc. When I play audio in Audacity I get random crackling and pops. Sometimes the playback will be fine for several seconds to 10s or 20s of seconds and then it would start popping again.

Unfortunately two things have changed… I upgraded to El Capitan OS and I changed from USB2 to FireWire via Thunderbolt adapter. I tried nightly builds, old builds, latest released build and they all do the same. My buffer is set to the default 100ms, which I don’t think is the problem. I tried 200ms. My audio interface is set to 48kHz 24bit so I made sure the project rate was set to 48K.

Any suggestions for me to try?


Audacity 2.1.1 MacOS X 10.11 El Capitan.

Now its not doing it. I was wondering if having my external disk drive connected to the second Thunderbolt port was the problem. Still troubleshooting and trying to duplicate the popping.


You mean the problem is gone when you attach a Firewire harddisk to the chain?

That’s a typical fix for FW audio interfaces and Macs with the Agere FW800 chipset before Thunderbolt replaced FW. I’m not surprised it works with the Thunderbolt adapter too. These don’t have Agere chipsets, but apparently the same bug.

Someone’s been copying… :laughing:

Have you tried a better/shorter FW cable?
A FW bus extender cable works too.

After 10.11.1 you can probably forget about the fix, when Apple fixes their code. Again…

FW development has been frozen in El Capital. That means there will be no new development, only bug fixes. But it’ll continue to function for many many years as part of Thunderbolt. Even SCSI is still part of Thunderbolt.

What Mac OS did you upgrade from?

Note that if Audio to buffer in Audacity’s Recording Preferences is the problem, reducing it below 100 ms is more likely to help than increasing it. It’s perverse but that is currently the case.


What was the logic that made connecting a hard drive over Firewire help stop playback pops in FW audio devices?

Was that on older versions of OS X?


Thanks for the responses. In my last post I noted that I have both thunderbolt ports occupied, one to a 3T external HD and the second to the FireWire adapter going to my Motu Audio Interface. When I was playing a file in Audacity I had the external HD turned on and mounted. Yesterday and now today I can play audio in Audacity without the HD turned on or connected.

Shoot I lost track of the last version of OS X but it was the latest prior to El Capitan. Everything else is working such as Serato, and Ableton Live. The only data point I have is that Audacity was popping randomly when my external HD was connected and mounted.

I am running a test now with only the Audio Interface connected (FW-Thunderbolt). So far playback is working so far without any popping.


After working in Ableton Live 9 I brought a loop into Audacity and it was popping again. This time I reduced the default 100ms latency to 24ms, the value set in Ableton Live. The popping stopped. The external disk from yesterday may not have any correlation to the issue.


It’s a rare issue on any OSX version on Macs (Macbook, Macbook Pro, iMac) with one FW800 port. These Macs all have the Agere chipset. In some circumstances, audio interfaces don’t sync. They don’t show up at all.

With a lesser cable, the crackle, stotter or sudden noise bursts appear and disappear if the interface does show up.

This is usually the case with older gear. Noise suppression on the data pairs isn’t what it used to be, or isn’t enough for FW800. When coupled to a longer cable, even the slightest movement might trigger it. With harddisks, no problem. With audio or video, a big problem.

With a good FW harddrive after the interface, noise suppression goes up because the second port ends in a device. It’s not “open”. But that’s my guess, as there is very little info, especially from Agere.

Since Mini’s, Mac Pro’s and non FW Macs don’t show this “3rd party hardware problem”, Apple ignores it. And even most interface manufacturer’s helpdesk operators don’t know it.

All these devices work on FW400 ports and other FW800 ports.

Most affected are older interfaces, but I’ve even seen it with brand-new gear from lesser manufacturers.

Until now, I figured the TB to FW adapter to be free from it, but apparently not. And apparently, code is involved?

Excellent. It’s interesting that Ableton also has a low latency set. Does playback pop in Ableton if you increase its latency?


Thanks for explanation, cyrano. There could always of course be an opposing effect where increased CPU activity if the drive was “doing something” (such as a Time Machine backup) could harm recordings or playback.


I’ve never known Time machine to provoke it, but Spotlight indexing could have to with it, fi.

Network seems to be well isolated too. Sleep an Speed stepping are two others that sometimes create havoc.

I haven’t tried higher buffer settings in Ableton. In fact, in the setup in preferences it only allows 32,64,18,256,512,and 1024 samples @ 48kHz so mine is set to 512 with a total round-trip latency (Input + Output) = ~24ms.

Everything came crumbling down when I upgraded Yosemite to El Capitan and my Motu via USB was not working. This led me down the path of purchasing the FireWire to Thunderbolt adapter and connecting the Motu that way. Prior to this, my Motu was connected via USB and Audacity worked just fine even with the default 100ms.

All is well for now.