Audio in Firefox (YouTube) slower after launching Audacity.

Audacity 3.0.4 flatpack

Operating System: EndeavourOS
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.14.6-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-2500K CPU @ 3.30GHz
Memory: 31.3 GiB of RAM
Graphics Processor: NV137
Audio subsystems: Pipewire, Alsa, Pulse, Jack.
Audio Hardware: Behringer U-Phorea UMC204 (USB) pro audio interface.

The following applies to a fresh install of Audacity with no changes to any of it’s settings settings.

When I am watching Youtube in Firefox and I launch audacity which takes 25 seconds of annoying popping and snapping noises the audio speed is reduced noticeably, but is still synced to the video, so it’s slower too then, and the audio tracks in audacity are not congruent to what the song length of the loaded audio tracks are supposed to be, but longer by a few seconds each given the actual song length. :astonished:

I am splitting albums I transferred from CD’s (Years ago) into single tracks and using the song lengths to more easily hone in on where the songs end/start, so I can watch videos and do my work, and don’t have to listen to to much of the music… (Multitasking), and the songs are increasingly further off as I go along. It doesn’t help that I have a lot of albums that are works of art as a whole where songs flow out of each other, often without any breaks or fading between them (Pink Floyd, Gong, King Crimson, Tangerine Dream, Zappa…). I know I’m a freak! :ugeek: (<:

I have no problems with system sound events, Ardour, or Audacious in that regard.

I know: One thing at a time, but I don’t have time in surplus to open several issues all for which I seem to be the only one to experience (which is strange) and filtering in the search doesn’t seem to change anything in the results when trying to see if the issue is already reported and the lists are way too long to traverse with everything marked as either “Closed” or “Resolved” and not one as “Open”, and I keep getting “sorry no results found” so if anyone can help with these, or the developers can add to their “to do list”:

I would also like to be able to set separate starts and ends for each song ([ctr]+ method), rather than having one end and start to the next song being one and the same, as I am having to do this more than once to allow room for fades which I also would like to include in the separated tracks right then and there if somehow possible, because one song’s end may be after the next songs start, and a simple cross-fade will not suffice.

The volume slider also doesn’t work at all. :cry: My DE is KDE Plasma and when I try to change the volume in audacity I get the “closing application” animation (Fall apart) on the widget, indicating that the volume slider is an application on it’s own, rather than a widget in audacity, or at least Plasma thinks it is, and that just doesn’t sound right, so if an intentional for whatever reason, it’s not working.

The interface is tiny and nearly unreadable at 4K (I am old), and the pixel snapping zones way too tight to use efficiently and without errors.

I can’t find where to turn off the reverse play direction when I move the mouse to the left of the place indicator which is immensely annoying, and should not be a default behavior… Really, who needs that? The :imp: “Satanic panic” :smiling_imp: was over in the mid 80’s!

When exporting by label I get 01-Songname, 02-Songname, and would prefer 01 Songname, 02 Songname when exporting: we are way beyond the 8.3, no spaces or special characters file naming conventions of DOS (at least in Linux), so if there is a way to change that behavior I would love to know how, because there is no option in the preferences to change it.

Thanks to all willing and able to help, and for all you do to bring us great FOSS alternatives.

Are the tracks 8% longer than they should be? If so, that would probably be due to a sample rate conflict. Do you know what the sample rate of the imported file is supposed to be? (You can check the file here: MediaInfoOnline - MediaInfo in your browser

Do you recall how you did that? Did you record them, or digitally “rip” them? If you ripped them, then they should have a sample rate of 44100 Hz(44.1 kHz). Please check with the MediaInfoOnline link (above) to check that they actually are 44100 Hz sample rate.

Where did that come from? Is it officially supported by EndeavourOS?

I’m not sure what you are asking. Perhaps “splitting” the track is what you want: “Edit menu > Clip Boundaries > Split” (Edit Menu: Audio Clips - Audacity Manual)

Which volume slider? One of these?
If so, which one?

This is a known issue. High resolution displays (HiDPI) have become quite popular over recent years, and the Audacity developers still have work to do to fully support HiDPI (It’s a big job). You may find some tips here to improve it: HiDPI - ArchWiki

It isn’t the default behaviour, at least it isn’t the default when Audacity is built correctly (we don’t make the flatpak version).
Please provide steps to reproduce this behavior.

For portability, it is best to avoid spaces in file names. Even though Linux has few restrictions on file names, Audacity uses the same naming convention on all platforms so that there is consistency across platforms. It is highly recommended to apply “best practices” when naming files, especially if the files may be used by others.
The Export Multiple interface is already quite complex - I doubt that the Audacity developers will be keen on adding even more options.
However, if it is important to name the files as “01 Songname, 02 Songname,…” then you can do that by making your labels “01 Songname, 02 Songname,…” and disable the automatic numbering in the Export Multiple interface.