audio import truncated

I am running version 2.1.0 on OSx 10.10.2
When i input audio files they are truncated to 45 minutes.
I started with wma format, converted to mp3 and tried that, converted to wav and tried that; for all the formats import length is 45 minutes.
For all of them when I listen to the audio file (all formats) I get over an hour recording.
The recording is of a church choir service so there are periods of quiet.
The WMA file came from a recording device that I have imported in the past without issues. The truncation is happening for two different WMA recordings.
At those time I was using older version of the OS X and Audio (?1.x).
Thanks for any help provided. I can upload the file to google drive is someone wants to see if they can import the full audio.

Wait. You import the file and it says 45 minutes but it plays for an hour?

Thanks for trying to help. When I listen to the recording with iTunes or VNC… whatever the length of the recordings are over an hours.
Then when I try to import them into Audacity, Audacity only has the first 45 minutes.

Are you getting all the content speeded up and higher pitched in Audacity, or getting the correct speed and pitch but missing all content after 45 minutes?

What is your Audacity project rate at bottom left?

Do you have sufficient disk space? What does it say at Audacity > Preferences… then the Directories section ?