Audio crackling very terribly, when it does work at all

OS: Kubuntu 14.04LTS
Issue: Audio doesn’t work.
Version: Audacity 2.0.5-1ubuntu3.2:amd64

The audio crackles very terribly when it does work, if at all. NOTE: Audio on file might be high.
See video:!2VckiLCT!Vmioj2jonUIQ-Zig4fUBbpsUZMzUhGnEpf__zhwh_rs
The file it was asking to recover was the one I previously tried opening.
I deleted the .audacity-data folder multiple times and tried purging and reinstalling it.

Does this possibly have something to do with the Phonon media backend that KDE uses?

Try changing the recording and playback devices in the device toolbar to the “hw” options that correspond with your sound card. Note that this will tell Audacity to use the ALSA drivers directly (bypassing other sound system “layers”), which means that Audacity will require exclusive access to the sound card, so you need to ensure that no other applications or services are accessing the sound card when you start Audacity.

Well, that’s a simplest fix I’v run across in a while. It’s working perfectly fine now.

As a side note, it’s definitely encountering a buffer underrun when using pulseaudio.
There are hundreds of lines stating “ALSA lib pcm.c:7843:(snd_pcm_recover) underrun occurred”.
But directly using the hardware did fix the problem.

Thanks for the help.

Yes, it’s usually possible to fix that by tweaking the buffer settings, priorities, sample rates,… but much easier to just bypass it all :wink: The default configuration of PulseAudio is generally not optimised for high performance, but for flexibility and reliability with general purpose software (media players, web browsers et al).

For “serious” audio production, Jack Audio System is the way to go, but it can be tricky to set up right (ideally it would be used with an optimised low-latency kernel), and is a bit OTT for most users. Using ALSA directly with Audacity is usually a good compromise.