Audaicity recording playing fast Win7x64/Audacity 2.0

Long time user of all the “old” versions of Audacity and I recently built a new computer and cannot get Audacity to work like it used to. Basically, if I start a recording in Audacity and start playing a YouTube video, Audacity seems to be recording everything correctly. But before I even export the file as a MP3, just trying to play the recording in Audacity, the file plays WAY TO FAST. Trying to adjust the time on the Audacity Edit Toolbar doesn’t work. I’ve tried a number of things and can’t figure this out so I thought I would ask the experts.

Some details about the system:

Windows7 x64 SP1
Asus XP Sabretooth MB
I7- 960 Quad Core 12GB RAM
Audacity 2.0.0 (Unicode)

In the “Sound” devices, Playback is Speakers and Recording is “Stereo Mix.” If I play any music or video, the “little green bars” on both the Recording and Playback tabs “bounce” like they’re supposed to.

In Audacity, Recording is set to Stereo Mix / 2 (Stereo) Input Channels. I’ve tried adjusting both the speakers and mic to various settings and the playback is still much faster than what is being recorded. Recording seems to be normal. Waveform looks good, the record meters are “bouncing” like they should.

I do not use iTunes and have no Apple software installed. The system is still pretty virgin with only Office 2010, Adobe Flash, Adobe Master Suite and Firefox installed other than Windows Updates and necessary drivers for the system.

Here is a copy of the Audacity log

15:29:09: Audacity 2.0.0
15:29:09: Error: Couldn't find symbol 'MainPanelFunc' in a dynamic library (error 127: the specified procedure could not be found.)
15:29:10: Trying to load FFmpeg libraries...
15:29:10: mLibAVFormatPath ('C:Program Files (x86)FFmpeg for Audacityavformat-52.dll') is not empty. Loading from it.
15:29:10: Looking up PATH environment variable...
15:29:10: PATH = 'C:Windowssystem32;C:Windows;C:WindowsSystem32Wbem;C:WindowsSystem32WindowsPowerShellv1.0;C:Program Files (x86)ATI TechnologiesATI.ACECore-Static'
15:29:10: Checking that 'C:Program Files (x86)FFmpeg for Audacity' is in PATH...
15:29:10: Warning: FFmpeg directory is not in PATH.
15:29:10: Temporarily appending ';C:Program Files (x86)FFmpeg for Audacity' to PATH...
15:29:10: Checking for monolithic avformat from 'C:Program Files (x86)FFmpeg for Audacityavformat-52.dll'.
15:29:10: Error: Couldn't find symbol 'avutil_version' in a dynamic library (error 127: the specified procedure could not be found.)
15:29:10: avformat not monolithic
15:29:10: Loading avutil from 'C:Program Files (x86)FFmpeg for Audacityavutil-50.dll'.
15:29:10: Loading avcodec from 'C:Program Files (x86)FFmpeg for Audacityavcodec-52.dll'.
15:29:10: Loading avformat from 'C:Program Files (x86)FFmpeg for Audacityavformat-52.dll'.
15:29:10: Returning PATH to previous setting...
15:29:10: Actual avutil path C:Program Files (x86)FFmpeg for Audacityavutil-50.dll
15:29:10: Actual avcodec path C:Program Files (x86)FFmpeg for Audacityavcodec-52.dll
15:29:10: Actual avformat path C:Program Files (x86)FFmpeg for Audacityavformat-52.dll
15:29:10: Importing symbols...
15:29:10: All symbols loaded successfully. Initializing the library.
15:29:10: Retrieving FFmpeg library version numbers:
15:29:10:    AVCodec version 0x344802 - 52.72.2 (built against 0x344802 - 52.72.2)
15:29:10:    AVFormat version 0x344002 - 52.64.2 (built against 0x344002 - 52.64.2)
15:29:10:    AVUtil version 0x320f01 - 50.15.1 (built against 0x320f01 - 50.15.1)
15:29:10: FFmpeg libraries loaded successfully.
15:30:31: Attempting to load LAME from system search paths
15:30:31: Loading LAME from lame_enc.dll
15:30:31: Error: Failed to load shared library 'lame_enc.dll' (error 126: the specified module could not be found.)
15:30:31: load failed
15:30:31: Attempting to load LAME from builtin path
15:30:31: LAME registry key exists.
15:30:31: Library path is: C:Program Files (x86)Lame For Audacity
15:30:31: Loading LAME from C:Program Files (x86)Lame For Audacitylame_enc.dll
15:30:31: Actual LAME path C:Program Files (x86)Lame For Audacitylame_enc.dll
15:30:31: LAME library successfully loaded

Rebooted the system several times and each time I launch Audacity, I get the same issues with recordings. And, Audacity was loaded to the default directory: “C:Program Files (x86)Audacityaudacity.exe”

If anyone has any words of wisdom, it would be appreciated. I have Googled this issue and can’t find a solution and there doesn’t seem to be anything on this board that works.

Anyone? Thanks in advance for your help!

When you say “way too fast”, how much “too fast” do you mean? 10% too fast? 50%? 1/4 speed? 10x , 20x too fast?

If you import a ‘known-to-be-good’ audio file into Audacity, does it play correctly?

You may be the poster child for a speed problem we’ve noticed on some, but by no means all users.

Any way you can record something “normal” like a microphone or plug your guitar into the sound card Line-In or something like that? Stay away from the recursive doubling-back sound pathways like Stereo-Mix or WAV-Out.

When you use all the sound pathways and services at once (Mix-Out), it’s a nightmare to figure out what’s wrong.


Another way you can help us enormously is figure out exactly how fast. “The on-line clip plays in 3 minutes and in Audacity, it’s 2:30.” Koz


I’ll do you one better.

This first YouTube clip I did. Started playing a Peter Gabriel song on YouTube and then started “recording” in Audacity. As you can see, Audacity is picking up everything correctly. Then later in the video (I kept it short), I start playing back what was just recorded. (Sorry for the poor quality. I just grabbed my phone and tried to hold it steady.

Then in this video, I just open a .mp3 file and play it for a minute. It plays fine.

Hope this helps!


Nope, Sorry. I don’t have a microphone or a guitar or any external recording device.

See above!


Thanks for the videos.

What is the name and model number of the recording device that has stereo mix? Onboard audio or USB sound card?

From your video of recording from YouTube, the recording cursor is travelling at about half speed, and playback cursor travelling at correct speed, with the obvious result that playback is too fast.

What is your project rate bottom left - the track rate is blurred but looks like 96000 Hz?

Please change host in Device Toolbar to Windows DirectSound, then in “Sound” in the Windows Control Panel, put a checkmark in both “Exclusive Mode” boxes. To do this, right-click over the speaker icon by the clock > Recording Devices, then right-click over stereo mix > Properties, then choose the “Advanced” tab. Do the same on the Playback tab for the playback device you are using. Restart Audacity. Try recording with a project rate of 44100 Hz.


Yes thanks, that helps “us” enormously. Now we need to see if we can help “you” :stuck_out_tongue:

We can see exactly what is happening - the recording is not keeping up with the audio so there are lots of bits missing. On playback, because about half of the audio is missing, playback gets through the remainder in about half the time.

The suggestions by Gale are a good place to start.
There are also some suggestions here:

Yes you must be correct, because the recorded and played back pitch is the same on the held notes at the start of the recording. I don’t often see videos of skipping but I have not seen one where the recording cursor was so dramatically slowed down.

Unfortunately isn’t quite complete but there is a fuller list of tips to beat skips here .



I’ll try to answer these in order.

It’s an onboard audio PCI sound card. It’s a Sabrent SBT-SP6C 6-Channel 5.1 Surround Sound 3D PCI Sound Card.

Project rate is 44100

Default setting is 16-bit PCM at 44100Hz. I’ve tried all the different settings in the preferences. Nothing changes.

I do understand what you mean about the record cursor traveling half-speed. That is weird. Never experienced anything like this before.

Tried all the setting you recommended. Still experiencing the same issue.

All of my sound drivers are up to date. Tried all the various “solutions” in the wiki, still have the same issue.

Next??? :mrgreen:

Are you sure those two “Exclusive Mode” boxes in Windows “Sound” are checked?

Have you rebooted the computer, not just come out of sleep or hibernation?

Other than that, I suggest process of elimination.

Do older versions of Audacity have the same problem? How about 1.3.12 ( ?

Set stereo mix to default in Windows “Sound” and record with Windows Sound Recorder ( ) .

Install SoundLeech and record with that ( ).

If both those have the same problem, try looking at your anti-virus or security programs. Anti-virus programs can cause single series of dropouts every 6 seconds or so. This is not the case here, but whatever security programs you are using could still be interfering with recording somehow. What anti-virus and anti-spyware do you use?

Are you running Skype or other permanently-on VoIP or instant messaging programs?


Here you go…

BOTH of the “Exclusive Mode” boxes are checked.

I have rebooted the computer numerous times.

Older versions of Audacity have the same problem, including V1.3 that was in the link you provided.

I installed SoundLeech! That works! Perfectly as a matter of fact. I can capture the sound (.wav), pull it into Audacity and it plasy fine, then export it as an .mp3. Works great, although I interface isn’t nearly as good as Audacity.

I’m running Microsoft Security Essentials for the antivirus. Disabled that and still can’t capture in Audacity correctly. Whether MSE is enabled or disabled, SoundLeech works.

Nope, no Skype or any other VoIP service.

I really appreciate the time you’re taking on this. It’s almost to the point that I’m willing to use SoundLeech to capture the sound and then edit and export it in Audacity. Not the most efficient way, but it will work I’m still open to additional suggestions.


We appreciate you hanging with us. This speed thing only affects a tiny number of people and only a tiny number of them sit still long enough for us to diagnose the problem.

" 'K, That’s nice. By!" and we never hear from them again.

Audacity 2.0 is very new and has a number of new features, filters, tools and services. It was the first few months before we even realized there was a problem.

“Have you noticed a lot of speed change problem postings…?”

Again, thanks.


Since you seem to be saying 1.3 versions have the same problem, it could be that the Sabrent is one of those few PCI cards that for some reason are not fully compatible with Audacity.

If you wanted to you could still try Windows Sound Recorder. Like Audacity, it can only record computer playback if the sound card offers this. It would exonerate Audacity if Windows Sound Recorder had the same issue.

If you have not already, also check in “Sound” in Windows for “enhancements” you can turn off ( Look for any similar or relevant settings in the Sabrent control panel if it has one (look in the Windows Control Panel for that).

And the “Default Format” above those boxes is 2 channel, 44100 Hz?



Yeah, the sound card could be the issue. There is no “device manager” specifically for the card. It just uses the Windows default interface. I could always go get a different card, but in the big scheme of things, it’s not really THAT important.

I tried the Windows Sound Recorder and it works fine as well, like Sound Leech.

And I did double-check…the “Default Format” and did conform they’re set at 44100Hz.

Thanks for all of your assistance.


If Windows Sound Recorder works then you should be able to get the same result by setting Audacity to use Microsoft Sound Mapper.

Steve, you had me going there for a minute. I thought I had tried all the various “Recording” settings. Switched to “Microsoft Sound Mapper - Input” and I’m still getting the same results.


have you thought about downloading the Youtube .flv (I use YTD) & open it with Audacity which strips out the audio tracks & see if your PC is still running the track too fast?

Well that does at least help to rule out some other possibilities. If Windows Sound Recorder can record then Audacity should be able to. So what we are looking at now is likely to be either that Audacity fails because it is a little “heavier” than Windows Sound Recorder and that is just enough to push it over the edge (this should not be the case unless your computer is seriously under powered), or something is interfering with Audacity.

I’m not able to help much with this next step as I don’t use Win7 (but Google is your friend).
Disconnect from the Internet (if you need to use Google, do that first :stuck_out_tongue: )
Shut down all non-essential processes and services, including your anti-virus, firewall, Windows Update, any “quick start” applications and anything that is non-essential in the sys tray. You can probably do that with something like “task bar > start task manager >processes >highlight the process > end process” (disclaimer - I don’t use Win7)

When you have your computer running as “lean” as possible, try recording with Audacity.

With it being a new computer with an I7, Quad Core, 3.2gHz and 12GB ram with a 120gb SSD drive, I don’t think system resources are an issue. My old one (a couple of weeks ago) was an old P4, 3.02gHz single core with 1GB RAM and a WHOLE LOT MORE BS software installed ran Audacity just fine. The big difference is the old one was XP Pro (32 bit) and now I’m running W7 Pro 64b bit. I have almost ZERO software installed on this new one.

I’ve tried disabling everything that can be disabled and still, no joy.

Tried that and that will work. I can just just about any format in Audacity (that it supports) just fine. But if I try playing ANY file in ANY player (MP3 in Winamp or a video in VLC player) and start the record function in Audacity, the same thing happens. I can play the file fine IN Audacity, but when I try to record with Audacity, it goes all wacky.

Oh well…