Audacity won't run after forced update.

My Audacity recorder stopped working a few days ago after Toshiba forced an update onto my computer.
Now whenever I open it, I get the following error - “Error while opening sound device, please check
the recording device settings and the project sample rate”

I had this problem a few years ago, and following the online help ended up fixing the issue. But this
time, the online help does not fix it. I have followed the directions enabling the Realtek Stereo Mix
sound device I’m using, which I believe is what it was using the last time it worked. It is enabled
and selected, and the sample rates selected. But in doing so, the progressive instructions did not
match what actually happened on my computer (menus were different than described, and settings buttons
and behaviours did not match what was described).

The procedure I followed was the one posted here, if it helps -


Anyway, despite following the procedure, it still does not work, and still gives me the above error

Can anyone help. I am not a computer whiz.
Toshiba c-55-b
Windows 10, 64 bit
My Audacity version is 2.1.1

One of the Windows security updates introduced managed and hidden devices. Lots of people’s productions collapsed when they did that.

I thought I had a note about that. We should wait for a Windows elf.

Is this it?


See also this sticky thread:


Thank you for your replies, but No.

The link you referenced to was about using the microphone, which is not my issue.

I’m trying to record things playing on my computer, like audio playing over the internet,
etc, or on an internal program. It was usually doing this thru Stereo Mix, I believe.

In sound settings, when I “make visible” and then activate Stereo Mix, there is no longer an option, like
there used to be, to make that the default device. Right clicking only gives me the options to

  • Enable (or disable,)
  • show disabled devices
  • show disconnected devices, or
  • properties

The “make default device” option IS available for my microphone, but not for the Realtek Stereo Mix
device. I don’t know if that is even the problem tho…

I activate the Stereo Mix device, check the sample rate setting, and have tried all the choice selections
on the toolbar, all to no avail.

Last night I downloaded and installed the latest version of Audacity222 into a separate directory folder,
and after launching had the same problem…It WILL NOT use my Stereo Mix device, gives me the
same error message.

THIS IS WHY I ALWAYS REFUSE THOSE F-ING UPDATES Microsoft and Toshiba are always trying to push
on me! They always break something, and then I lose features and functionality.

Eventually though, they pry open your mouth with a crowbar and ram it down into you and you are
screwed, with serious consequenses to your work ability…

Try using the WASAPI method described here:

Did anyone ever solve the problem of Audacity breaking after a Windows update problem?
Haven’t been able to use it since, and the WASAPI fix mentioned didn’t work either.

See here:
Apparently this applies to all recording devices, not just microphones.

Thank You Steve that did it WooHoo!!!...