Audacity won't record

Hi all,

I’m on Windows 10, Audacity 2.1.0.
It’s not that it’s “recording” but not picking up any noise, it’s that when I hit record the line just stays there and blinks a bit.

I just downloaded Audacity for the first time (I intend to use it for some voice acting stuff and hopefully to record some of my music) : first I downloaded the .exe installer.
I’m recording with a CAD u37, so I changed the settings to MME, Microphone CAD audio, 1 (Mono) recording, Speakers CAD audio. When trying to record, I get an error message,

Latency Correction setting has caused the recorded audio to be hidden before zero.
Audacity has brought it back to start at zero.
You may have to use the Time Shift Tool (<---> or F5) to drag the track to the right place.

Looked up this error and disabled overdub, which got rid of the error message but didn’t resolve the issue (if I enable overdub, the error message comes back). I also disabled my computer’s default microphone (SST intel audio device (WDM) microphone). My current default mic is my CAD u37 and my computer speakers are my default speakers.
I uninstalled audacity and reinstalled it, but it didn’t do anything. I uninstalled it and reinstalled it again, this time the .zip file.

Does anyone know what this is? Is there something really obvious I’m missing? Have I left out any important info?

Thanks!

Have I left out any important info?

That’s good to go for a while.

You should know that reinstalling Audacity doesn’t reset Audacity. The Windows installer should ask you if you want to reset the preferences and settings. Say yes.

I also disabled my computer’s default microphone

Does that work? Disconnect the fancy microphone and try to make a plain internal recording.

Koz

(I can’t remember if I already responded to this or not: I’m sorry if I already have and it just hasn’t gone through)


Okay, so I uninstalled and reinstalled (this time 2.1.2 exe) and reset my preferences. I reenabled the default microphone on my computer and was able to make a recording, but when I plugged in the USB mic (and changed the settings back to Microphone CAD audio, 1 (Mono) recording, Speakers CAD audio) I couldn’t get it to work.

I can’t remember if I already responded to this or not

I write little notes to myself… You will be moderated until some number of postings goes by. One day you’ll wake up and your postings will be immediate.

You can get the flickering cursor when Audacity is trying to make sense of a damaged digital stream. Has the microphone ever worked?

http://manual.audacityteam.org/man/faq_recording_troubleshooting.html#pauses

Koz

Ah, thanks for your patience! Writing notes is a good idea, my short term memory is pretty abysmal.

The microphone is new: I hadn’t thought about it before, but after reading your posts I tried the microphone with the default Windows voice recorder and it didn’t work either, so the problem is either the microphone or Windows. Sorry about that.
After googling for a couple hours it seems like lots of people are having problems with USB compatibility/drivers/Windows 10, so I guess I’ll just keep looking/poking Microsoft and the microphone company until I can figure it out.

Thanks so much for your help!!

Okay! So! I went into my device manager and uninstalled all of my USB stuff, rebooted (so the system would reinstall them), changed the preferences to disallow the computer from shutting off any of my usb devices to save power which led to me being able to record!

One small problem: When I go to play back the audio recorded in Audacity, it’s silent. I tried recording in my voice recorder, and that records, so now it seems like it’s legitimately an Audacity-adjacent problem. Any idea how I can hear my audio?

Thanks so much!

Any idea how I can hear my audio?

I do. When Windows sees an audio device, it naturally tried to record from and play to it.

Back into Windows setups and tell it where you want the playback audio to go.

Or unplug the microphone. I think once you set that the first time it should stick.

Koz

Yes! That did the trick! Thank you so much!