Audacity won't record through mic, stalling at 0

I’m using Audacity 2.1.2.

Yesterday I got a new mic set in the mail that is USB connected. It has a port for headphones, too. Right away I installed Audacity, and with a bit of fiddling around with my headphones, got Audacity to be able to play a backing track and also record through my mic at the same time, while I could hear through my headphones.

Today, however, Audacity seems to not want to work with me. I’m having SEVERAL issues, and have searched the forums, YouTube videos, everything, and nothing is seeming to fix the problem. I have restarted my computer twice and uninstalled and reinstalled Audacity already.

  1. For some reason, nothing will play through my headphones in the USB connector. I can play through my computer’s headphone jack, so I’m just going to leave it at that and not fiddle around with it too much.
  2. It won’t record through my mic. It’s just not picking up any sound from it. Although, my computer isn’t picking up through my microphone, either, so that’s probably a problem with my computer.
  3. Whenever I try to record through the USB connected mic, it does that thing where it stalls. Before it was showing the Latency error and was stuck at 0. Now, the latency error isn’t showing up, but it is still stuck at 0. The backing track won’t play, either. Nothing happens.

I have checked my speaker settings, and it’s all set to the mic. In Audacity, I have the mic set to the USB and the speakers set to the Intel SST Audio Device as it just won’t play through the USB at all. Overdub is on, software playthrough is off. Audio to buffer is set to 100. I have tried troubleshooting the speaker issue with playing sound, and my computer knows something is wrong but it can’t fix it.

I want to be able to record through my mic and play something at the same time. It works perfectly if I have the mic set to my computer’s mic, but as soon as I try the USB mic the backing track doesn’t play - it just stands still, everything stuck at 0.

I’ve attached pictures where I thought they were relevant. If anyone can give me any advice on what to do, it would be really appreciated. I forked out a lot of money for the mic, and I have no idea why it was perfect yesterday but refuses to work today.
audacity recording.PNG

Well, try to get the USB mic recording into a clean empty project, no overdubbing, before you go further. What is the make and model number of the mic? Does it record if you set Audacity to record in stereo?

Reinstalling Audacity makes no changes to it unless you enable the “Reset Preferences” box half way through the installer process. Try that. If the reset does not help you can try increasing “Audio to buffer” in Audacity’s Recording Preferences.

Also do a proper cold boot. Click Windows button, Power menu, hold SHIFT while clicking “Shut Down”. Default Shut Down without holding SHIFT reuses the same kernel session, and so does not replenish computer resources properly.


I’m having the same problem. It was working fine for me with my USB mic, now it stays stuck at 0 as you have indicated in your picture. Once or twice it started to record, but after three or four seconds got stuck. If I let it keep jamming itself, then Audacity sends the message: “Latency Correction setting has caused the recorded audio to be hidden before 0.”

If so, then apply the same suggestions stated in this topic. Have you tried all those yet? Also plug the USB mic into an empty USB port, and try a different USB port or a different USB cable.