Audacity wont Record in my ASIO Build

Hi Everyone,

Hopefully this is the right place to post, tried to go to Windows but would not let me go there and post…

I built version 2.0.3 with ASIO Support (Installed the Steinburg SDK and compiled - didn’t go smoothly but I digress)…
We are using Windows 7 now and the old version (1.3.3 on Windows XP) would see the DigiDesign Sound cards as a Input Source
and could be chosen(Stereo Mix), but this version does not see that input source…

Was told that this would solve the problem (ie compile with ASIO Drivers), and alas - the Digi Design card is now an available source. But,
when I attempt to record I get nothing, bar doesn’t even move, no meters nothing. If I click preferences, Recording and check Software Play
through while recording, viola, we get meters and it records.

Also found that if I have a blank recorded line above the current and click overdub in Preferences - then that will record as well.
If I do not have Overdub or Play through Checked (On) , Nothing records.

Saw someone else had this problem but never really saw a solution.
http://audacity.238276.n2.nabble.com/Audacity-recording-problem-with-ASIO-td258549.html

  • so figured I would throw this out there…

Maybe somebody knows whats up here. Bug Maybe?

Thanks,
Todd Baker

I moved the topic for you. You have to be logged in to post. I don’t know what else the problem could be.

It may not be a digression. Did you eventually get an error free build?

If you have an MBox, Audacity does not explicitly support them, and using an MBox rarely worked in Audacity without installing the Digidesign wave driver for third-party software. It is best to use Pro Tools which is designed for the MBox and other Digidesign hardware.

Anyway, please give the exact make and model number of the audio device you are using.

If you plug in the device after starting Audacity, you need to use Transport > Rescan Audio Devices.

You mentioned “stereo mix” which is meant for recording computer playback. Exactly what input have you chosen in the third (input) box in Device Toolbar ? What options do you see there?

Have you chosen the ASIO host in the first box of Device Toolbar? If not, you aren’t using ASIO capability.

Exactly what project rate have you chosen bottom left of Audacity? Sample rates must be matched everywhere with external devices. Does your device have its own control panel in Windows and have you set the same sample rate there?

Have you enabled stereo mix for this device in Windows Sound? See Missing features - Audacity Support .

It’s not easy if people use Audacity with hardware meant for ProTools. Have you checked to see if Digidesign require special drivers to use your device with other than ProTools?

If you built the latest Audacity 2.0.5 it might help. That has a later version of PortAudio than 2.0.3.


Gale

Dear Gale,

Thanks for replying (and working on my permissions)… I will try to answer most of you replies, but must admit - I posted some incorrect stuff about my setup. Here is the deal.

I did get an error free build. It seemed to have problems finding the ASIO stuff , the path seemed wrong in the Build Log. I actually put it where it was looking (ASISDK2.3 INSTEAD OF ASIOSDK2.3). I also left it in both places, have NO IDEA why the build seemed to think it was in the first choice directory (ASISKD2.3)…Environment variable was right…

The sound card we are using is RME DIGI96PAD. Some of our studio machines use these cards. When I open Audacity the device choices are set as follows:
Audio Host - ASIO
Output Device ASIODIGI 96 Series
Input Device ASIODIGI 96 Series
Input Channel Mono

Sorry about mentioning Stereo Mix, I was looking at the wrong machine. The sample rate matches between the driver for the board and Audicity settings (44100).

As I said someone else seemed to have this exact same problem…

OK, so this is actually nothing to do with DigiDesign and ProTools.

What drivers are you using for this device and are you on 64-bit or 32-bit Windows 7 ?

According to http://www.rme-audio.de/old/english/download/drivers.htm there are no drivers for later than Windows XP and according to DIgi 96 PAD 8 Support windows 7 ?? !! (Page 1) — Vintage stuff — RME User Forum while those XP drivers may work for Windows 7 32-bit, there are no 64-bit drivers.

Is it a problem if you leave Overdub on in Audacity? Is the empty track required, or only having Overdub on?

Are you saying Overdub or Software Playthrough was not in your case required when you were on XP?

According to DIgi 96 PAD 8 Support windows 7 ?? !! (Page 1) — Vintage stuff — RME User Forum the drivers will only support Windows 7 under ASIO, but what happens if you choose Windows DirectSound or MME host? Does Audacity record, and if so, is it necessary to enable overdub?


Gale

Hey Gale,

My fellow technician has been trying to get this machine to work, here are his responses:

The RME XP drivers on 32 Bit Windows 7

The 32 bit XP drivers do work with Win 7 but only the ASIO part, the WDM/MME drivers do not work with Windows 7.

Overdub only works if there is already a track with audio in it. Say track 1 already has audio. Then we can record on track 2 but sometimes the recording input stops on the new track at the end of the audio playing in track 1.

The XP systems worked fine without having Play Through or OverDub on. In our studios we can’t have Play through on. The OverDub setting also would not work very well in our case, especially since there has to be another track and it doesn’t seem to always record past the non-recording portion of above track…

Todd

Nonetheless those drivers were not meant for Windows 7.

Do other audio recorders misbehave in the same way?

Have you tried right-click over audacity.exe, choose “Properties”, click the “Compatibility” tab, then try an XP or Vista compatibility setting?

Audacity will always stop recording at the end of the selection if Overdub is on. If you need to retain a selection, use Edit > Region Save, remove the region then Edit > Region Restore later.

You could also try Tracks > Add New > Audio Track (or Stereo Track) then Append Record into that track (SHIFT-click on Record). But if Overdub is on, this may play a fragment of the previous recording every six seconds, due to an Audacity bug.

So that seems better than the other user you mentioned on XP.

Are you sure some RME setting is not expecting audio to be sent before it will record?


Gale

In case it helps…

I just built a fresh checkout of Audacity, built with ASIO support, and tried recording using an RME Babyface. I was able to record just fine. I did have the same problem I have with WDMKS in that the recorded audio has to be normalized (Amplify) to be useful.

In preferences, I do not have Overdub or Software Playthrough checked.

This is on 64-bit Windows 7.

Leland

Sorry for not replying here but I wasn’t really running point on this problem…and it appears we wont be going the RME direction to solve this…

To answer your questions earlier, no, we never had any problems with the RME card, and it never expected audio to be present before recording before… Since we are a distributed Windows environment, with literally hundreds of users who are not audio professionals, the amount of configuration by the user must be minimal…in reality, we don’t want them to change anything…

Thanks Leland for the update. I will try to download the latest and greatest, at some point, but am not real hopeful that it will change the result…
Have gotten into other things at this point, and the Tech who was working on this is probably going another direction with this. I appreciate all of your help.

Regards,
Todd Baker