Audacity won't recognise mp3 files


Just in the last few days I keep getting the following message when I try to import an mp3 file : “audacity did not recognize the type of this file if it is uncompressed try importing in raw data”. The file is definately an mp3 and not anything else and I’ve imported hundreds of them from the same same sources over the years. The weird thing is, the problem seems to be intermitent. One minute it imports the files and the next it doesnt.
I’ve tried re-installing audacity but I keep getting the same issue. Any ideas ?

I’ve tried re-installing audacity

Did you try resetting Audacity? In the Windows installer, there’s a place to check-mark that you want Audacity to kill off all your preferences and settings. If you don’t do that, all your settings and preferences will stay around (handy for version updates) and that can cause problems if there is damage somewhere.

Does it still fail if you right-click the sound file > Open With? (I think Windows will do that).

You can Import, Open-With and dragon-drop. It might be interesting if only some of them fail.


Set Windows to always show the file extension (, then check the exact name of the file.
Do the names of the files that fail end with “.mp3”?

Download “MediaInfo” from Get the MediaInfo version without installer, because the installer may have malware or adware. What does MediaInfo say about the files that fail to import?