Audacity won't read my recordings anymore.

So earlier I was recording for something, when I finished it and saved it, it did so. What really freaked me out was when I closed Audacity, it crashed. I checked to see if my recording was okay, but it turns out that Audacity is having trouble reading it. So I tried to open another file (which was completely fine since it was recorded weeks ago), but it happens again. I reinstalled Audacity and tried to open the same two files again, but this time it says “Warning - Missing Audio Block File(s)” Anyone knows what’s going on???

Which version of Audacity are you using? (look in “Help > About Audacity”)
Which version of Windows are you using?
Is your computer doing anything else freaky?

If you are using an obsolete 1.2 version of Audacity on Vista Service Pack 1 or later, this could be quite likely.

Get the current Audacity 2.0.6 from Audacity ® | Downloads if you don’t already have it.

Try installing 2.0.6 (or if you already have it, reinstall it) but make sure “Reset Preferences” is checked (ticked) - you’ll see it half way through the installation process.

Then open the project and if you see any warnings, choose Help > Show Log… . Press the Save button to save the log and attach the log here. Please see here for how to attach files: