Audacity won't overwrite files, even when told to [SOLVED]

Running Audacity 2.0.5 on a Windows 7 64 Pro laptop. New weirdness just started happening tonight. After adjusting the amplification on a track (splitting to 2 tracks, amp’ing each track separately, then re-joining), then exporting, I get the usual “file exists, do you want to overwrite”? I say “yes” and it exports just fine. When I then look at the folder I end up with 2 tracks, with the =original= track being renamed with a “0” (zero) on the end. I’ve never seen this before, in modding over 3,500 tracks. Any suggestions as to what might be going on? TIA…

Either you did not export as WAV before, or you are now importing WAV with the read-directly option rather than copy-in ( see “When importing audio files” in Import / Export Preferences) .

If you choose “read-directly” import then overwrite the imported file, Audacity renames the original file with “old” plus a numerical suffix and uses that renamed file as the audio source for the project. It can’t use your modified file as the audio source for the project, because if you undid the edits you made in Audacity, the original audio source would no longer exist.

Your modified exported file still has the original name, though it does have a new timestamp. Retaining the original timestamp would be a feature request. Deleting the “old” file after closing the project would be a feature request.

To avoid seeing the “old” file when you overwrite WAV files, use the “copy in” option when importing the WAV.


Thanks, Gale. I’m working with mp3 files in this case, and that’s mostly what I work with since it’s for my Zune player. I’ve never had this happen before and I only output mp3 files. I understand I’ll have dupe files if I’m converting formats, but not when I’m opening an mp3 then exporting back to mp3.


Then in that case I think it is an issue on your computer with your file manager program, your hard drive or some application that is monitoring and locking files. Audacity will always copy in the data from the imported MP3, so it does not need to retain the original MP3 file as audio source data.

What should happen is that when you overwrite an MP3, Audacity renames the original file immediately by appending “0” to the file name, then commences writing the new MP3 with the original name, then deletes the original MP3 that had “0” appended.

So some issue (such as I suggested) is preventing the original MP3 file with appended “0” being deleted. Does that “0” file disappear if you refresh your file manager window? Can you delete the “0” file? If not, some process is locking it, but it should not be Audacity that is locking it. Unlocker will show you if any processes are locking the file, and lets you quit the locking process and delete the file if necessary.


Hmmm. I wonder if they’re being treated as Read Only or somehow locked. I d/l’d the files to one folder, then moved them to my music library in Explorer by drag 'n drop.


You can right-click over the “0” files and choose “Properties” to see if read-only is set. I doubt it.

We can’t see your computer, but the application I suggested will let you see and remove a locking handle if that is the problem.

I don’t think it is an Audacity problem. The fact you have the “0” file shows that Audacity did what it is coded to do.


Will have to check tonight when I get back from hell, er, work! :slight_smile:


OK, so playing around last night, I checked a few files in the folder that’s been acting weird and that I haven’t yet adjusted and, yes, they were marked as Read Only. When I removed this in Properties, then exported them from Audacity, I wasn’t seeing the dupe files. When I just loaded a bunch more tonight, I forgot to change the properties and guess what?, got dupe files. Issue solved!

To make thing easier, you could try “taking ownership” of the problematic folder these files are in. .


Thanks, Gale. Part of the issue, I think, was that I didn’t do a cut 'n paste to move the files, but a drag 'n drop. THAT’s what usually effs with the properties, in my experience. Not a huge deal, just annoying. Thanks, again, for your help.


I’ve had the same issue. We have several Windows 10 machines and Mac’s that share the files. The issue happens with all of the devices. But up until a few weeks ago it was putting “-oldX.wav” now it adds a digit. The “-oldX.wav” was easy to see and we knew it was not the newest version. Adding a digit is VERY frustrating as our file names are like “A290100.wav”. I looked at the properties for the files and see I have “read/write” permission but “staff” and “everyone” just has “read” permissions. I have thousands of files in hundreds of folders, it would be a nightmare to change the permissions for all of them. Is there a way to get the “-oldX.” put back?