Audacity won't open in Sierra (10.12.3)

Audacity 2.0.6 will not open since I updated to Sierra a couple of days ago.
I keep getting the following message:

“Error while opening sound device. Please check the playback device settings and the project sample rate.”
The particular file I tried to open is a small mp3, which I have previously edited in Audacity, but since updating to Sierra, as soon as I hit the ‘Play’ arrow, up comes the message (above).
Any help would be most appreciated.

How complex is your music system? If you’re playing to built-in speakers (MacBook Pro) or the headphone socket (Mac Mini), I expect it to work right out of the gate. If you’re playing to a complex USB, FireWire, Thunderbolt, WiFi or Bluetooth music system, you may need to find out if your devices are supported under Sierra. It needs to say so specifically in the instructions.

Apple (upper left) > System Preferences > Sound. See if your music system is listed there.

After you get that sorted, look at the Audacity Device Toolbar and see if you’re pointing to the right thing.

http://manual.audacityteam.org/man/device_toolbar.html

Most of that is Windows, but there are Mac fragments here and there. Your Stereo/Mono settings are required to match. Some devices will vanish if you get that wrong.

Koz

Audacity is launching, or you would not be able to hit the Play button or see the error.

It may not be directly related, but be aware that Sierra did not exist when 2.0.6 was current. Have you considered updating to the current Audacity 2.1.2 from Audacity ® | Download for Mac OS? Before launching 2.1.2, reset Audacity preferences. To do that, open Finder, use Go > Go to Folder and type:

~/Library/Application Support/audacity/

In that “audacity” folder, delete the file “audacity.cfg”.


Gale

Hi kozikowski, Thanks for your reply.
I’m not using a music system, just the built in speakers in my MacBook Pro. Should I delete my current version of Audacity and install the latest version?
I have only started with this problem since upgrading to Sierra OS.
Any advice, much appreciated.

Did you see this reply?


Gale

The same is happening for me. 10.12.3 will not let me open Audacity.

I was having troubles with my mic on Audacity, it wasn’t picking up the sound. I am a podcaster, and use this same mic daily. Its a Audio-Technica ATR2100-USB. For some reason Audacity wouldn’t pick up my voice. When I would record, it looked like it was picking up sound. But then when I played it back, there was no sound. I checked the headphones, and the computer speakers. Still nothing.

I closed Audacity and reopened…same problem.
So I rebooted the computer…same problem.
So I deleted Audacity and redownloaded the newest version.

When I went to open Audacity…I got this message in a popup…
'Audacity can’t be opened because it is from an unidentified developer."
Your security preferences allow instillation of only apps from the app store and identified developers.

So I tried a few things. I tried downloading Audacity from another source/website. Same message
I tried what the Apple forums mentioned, by opening Audacity by right clicking and pressing the ‘open from the shortcut menu’…sadly there is no 'open from the shorcut menu option.

I tried going into system preferences > Security privacy > general and privacy tab, both…no options to change anything to open audacity
I also tried adding the ‘open from the shortcut menu’ option to the right click…no options to add that :frowning:

Any suggestions?

Audacity does not fully support Sierra due to aggressive security changes made by Apple.

I would recommend trashing your existing Audacity versions. Open Finder, choose Go > Go to Folder and type:

~/Library/Application Support/

Delete the “audacity” folder.

Then try “Audacity Mac 2.1.3 RC1 - DMG (RC for testing only)” from Audacity download latest version. That version is codesigned with an Apple Developer certificate. All being well that will become the 2.1.3 version in a few days’ time. It should launch OK if you install it yourself then use it yourself (as opposed to some other user installing it and you use it which could be a problem).

The correct instruction for 2.1.2, assuming Gatekeeper is not completely blocking it, is to right-click over Audacity.app, choose Open then use the Open button in the dialogue that appears.


Gale