Audacity won't open for account, opens for Domain Admin

I have a user who uses sound equipment. The computer is on a domain network. They’ve been using this computer and Audacity for a couple years with no issue.

All of a sudden, when they try to use Audacity, the splash screen shows up for a fraction of a second, then nothing. No process, no window. It just completely crashes.

If I log in as the domain admin, Audacity opens without issue.

I’ve tried uninstalling/reinstalling, cleaning registrys, running the program as an admin on the domain user. Nothing.

Windows 7 Pro, x64.
The original version was a 2.x version (I don’t remember which one)
I’ve tried installing 2.0.5 and 2.0.6 with the same issue.

It doesn’t seem there’s anything permission wise going on, because nothing permission wise has changed.
But it does open for the domain admin, which points to permissions.
Any ideas?

See if there are any pointers here: Redirected appdata permissions error - #2 by Gale_Andrews .

Does the problem occur only if the user logs on using a specific machine? If so, there could be an issue with the sound card on that machine.

It would be unusual, but do you allow users to install software specific to a machine or specific to their account? If so you may want to check that out. An unauthorised sound capture program, plug-in or security program could cause Audacity not to launch.


Oy! That did the trick.

I’m going to simplify it here for others with the same issue.

Make sure Audacity is first installed

Step 1: Navigate to the folder where Audacity is installed (Typically C:/program files (x86)/audacity)

Step 2: Open up the Audacity folder

Step 3: Create a folder in Audacity called “portable settings” (C:/program files (x86)/audacity/portable settings)

Step 4: Open notepad, and in it type:


Step 5: Save as in the portable settings folder, title it “audacity” and save it as a .cfg file. You may need to save it as a text file, then rename the extension in windows explorer to .cfg

Step 6: Audacity should open right up when you click the shortcut or .exe itself!