Audacity won't off my macbook pro's line in as an option

I installed ubuntu and am now using audacity 1.3.13 and cannot figure out how to select the line in on my macbook pro as a recording device. I was able to when I was using the Mac OS, but now I suppose ubuntu doesn’t want to read my headphone jack as the line in jack, which it is. I am only offered pulse, my soundcard, and default in the drop down box for recording device. The same is true when I go to change my preferences. Also, my pulse volume control won’t offer my line in port as an option either. Like I said, I know that my headphone jack functions as my line in because I’ve used it that way before successfully. Does anyone know of a way I can get pulsevolume control and audacity to pickup my line in?

If you have one of the smaller MBPs, then yes, you need the software that “knows” how to switch that one connection between the different jobs. The 15" (mine) has two connectors, but the 13" (my friend on 6West) has only one.


Maybe the linux drivers (on the kernel version you’re using) do not support that…

If you run alsamixer on the command line do you see any option to switch between input/output?

No there was no option that I saw to select input. When i looked at the capture window there was only a mic label. I’m going to try to set up audacity with jack and see if that works. Do you know where I would be able to find the software to read a macbook pro’s line in on ubuntu? Also, would buying a line-in adapter be an option? Or would I then need drivers for that as well?