Audacity won't launch. Help.

I had Audacity 2.1.1 installed but I hadn’t used it in months. Then, when I went to use it the other day, it never got past the start-up logo. I waited but the editor never appeared. I had to use the Task Manager to close the program.

So I tried upgrading to 2.1.2. Same result.

So I did a full uninstall and reinstalled 2.1.2. Same result.

So I tried reinstalling all of my codecs (K-Lite 12.x). Audacity still hangs on launch.

So I tried to reinstall again, telling the installer to Reset my old settings to their defaults. Didn’t help.

I’m using 64bit Win7. Other audio/video editors work, just not Audacity, and I have no idea why.

I believe it is getting hung up trying to load my codecs, but as I said, I already tried reinstalling them. I suspect it’s a codec issue because when the app is frozen trying to load, my audio goes out and I must reboot to get it back.

Can anyone help? TIA

So I tried reinstalling all of my codecs (K-Lite 12.x).

Did you try not installing all your codecs? Failing to launch can be any plug-in, filter, or add-on.


Should I uninstall all my codecs before trying to reinstall Audacity? I don’t recall ever having to do that before and I’d really rather not since everything else is working properly.


Codec packs generally are a bad idea unless they let you install only the codecs you need.

See Other reasons for non-launch of Audacity are audio drivers (which sounds likely from your description) or security applications interfering. If you boot into Safe Mode Audacity will probably launch but with no audio because the audio service is off in Safe Mode. You can use services.msc to stop or start services.

If it is an audio device issue perhaps you had an audio device driver update that was inappropriate. Audacity needs drivers to be optimal, which isn’t always necessary for player applications. See Updating Sound Device Drivers.


Thanks Gale,

K-Lite does let you chose your codecs, though I probably installed most (if not all) of it.

I have no reason to suspect my audio driver since audio is otherwise working properly. I wish I could see what was causing the conflict. :frowning:

Right now, my “work-around” is to run Audacity from a VM (“Windows 10” using “VM Player”). Technically, Audacity is still running on the same computer… drivers, codecs & all… just by way of another OS, suggesting a conflict somewhere in Win7. I may try disabling all my startup apps till I find the culprit.

I’ll report back with my finding as soon as I get the chance.

Generally, Audacity is much more finnicky about audio device drivers than other player applications. But I assume given the virtual host is Windows 7 that you can’t get “device passthrough” where the device runs as if it really were on the guest system, even if incompatible with the host. So your interpretation might be correct.

Note that if any other application is taking exclusive control of the sound device then Audacity can’t use that device.

Services as well as applications can be a problem. If you exit an application, that does not necessarily exit any background processes that it might create.


Briefly, when I launch Audacity, the logo appears and then nothing. The app never opens. :frowning:

After a bit of detective work, I discovered I can get Audacity to run two ways: 1) Run it from a “Virtual Machine” (I’m using 64bit Win7. I installed Win10 under “VM Player”) and Audacity loads/runs just fine. SAME COMPUTER. Or 2) Disable either of two Win Services: “Windows Audio” & “Windows Audio Endpoint Builder”. Disabling one or both disables my audio and Audacity loads just fine. Useless, but it loads. :smiley:

Since Audacity works when run from a VM, I thought maybe the problem was my drivers, so I updated everything but it made no difference.

The only other possible cause I can think of are my codecs, but I don’t know how to selectively disable them individually till I find the culprit.

Any help is appreciated. I’ve had this problem for a long time. I’m just getting back it now.

(Audacity 2.1.2.)

The answers are the same as a long time ago, so I merged the topics so we can see what was said before in one place.

If you mean audio format codecs for encoding, as in K-Lite, they are unlikely to be responsible.

Are you talking about disabling specific audio devices? Did you update your sound device drivers from the computer manufacturer’s web site? Using Device Manager to update might not help.

Have you tried disconnecting the internet and turning off your Anti-Virus or security applications? Such applications can sometimes interfere with Audacity. If you find that is the problem, you can probably tell them to treat Audacity as safe and not scan or block it.


Hi Gale,

Since I had new information and my original assumption was wrong, I felt it deserved a new topic, but it’s not important.

I disabled all my audio codecs using K-Lite’s “Codec Tweak Tool” but it didn’t help so that wasn’t the issue.

As I stated in my new post, I updated ALL outdated drivers (including two related to “Sound & Audio”. It made no difference. If there are different audio drivers for my Realtek onboard audio, I’m not finding them. :frowning:

Disabling my AV (Avast free) doesn’t have any effect, as does rebooting using “Diagnotic Startup” (“msconfig.exe”) with all Services & Startup items disabled (sans the two “Windows Audio” services mentioned in my post.)

So the mystery continues. :frowning:

UPDATE: I tried rolling back my audio driver for my MoBo to the original from 2011 but it didn’t help. I searched “audio” drivers from my copy of “Driver Booster” and found a ton of audio related drivers (MoBo, Windows, my internal ATI TV card, my external WinTV device, my WebCam, my nVidia video card has HD Audio drivers too.) Removing those nVid drivers didn’t help.

Which got me thinking that Audacity is probably trying to access the wrong audio device when it starts and can’t. But Audacity has no ini file with my Device Settings that I can delete, and when I start Audacity with my Windows Audio services disabled, the list of Devices is empty.

It there a way to reset Audacity to it’s default settings?

UPDATE 2: i completely uninstalled Audacity v2.1.2 and installed an old copy of Audacity 1.2.4 I found in my backups, which worked. I then uninstalled it and reinstalled v2.1.2 Didn’t work. Same problem. :frowning:

Is it a branded computer like Dell or Lenovo? If so, the best place to look is their site. Or did you build the computer yourself? If so, the best place to look is the motherboard manufacturer’s site.

The Realtek site offers generic drivers that are not matched to your hardware. Occasionally if there is a major issue with the “proper” drivers from the computer or motherboard manufacturer, Realtek generic drivers can help (for a Realtek device).

Driver-finding applications are, at best, no better than you can do by searching for drivers yourself. If it is a reputable application, it might save you some work. At worst, it could be a threat to your computer. I would recommend undoing DriverBooster’s changes back to the day you installed it, and preferably totally uninstall it.

Yes, as described in the FAQ FAQ:Installation, Startup and Plugins - Audacity Manual. The simplest way is to reinstall 2.1.2, making sure that you enable the “Reset Preferences” box half way through the series of installation windows.

Well, you could try the latest 2.1.3-alpha (top of . It’s not an installer, just a ZIP file. That version can usually step over any individual audio devices or sub-devices that are problematic.

You could also create a DxDiag Report and attach that. Please see how to attach files to forum posts.


(Sorry for the late reply.)

Yes, I built the computer myself. I’ve completely uninstalled v2.1.2 several times and selected “Reset Preferences” when reinstalling (which shouldn’t matter since I used an Uninstall utility that even removes latent Registry values) but it didn’t make any difference. I think by default, Audacity is trying to use the wrong device.

As I noted previously, a very old copy of Audacity v1.2.4 works (no longer installed in case of conflicts), so something changed since then. I found a copy of v2.0.0 and tried it, but it too did not work.

I’ve uninstalled and reinstalled my MoBo audio driver using the latest version off their website. then tried the 2.1.3 alpha, but it does the same thing (logo appears, stays on screen and the app never appears. I must kill the process from the Task Manager, after which I lose all audio till I reboot.)

Attached is my DxDiag report following the crash. Thanks.

UPDATE: Ah! I was right! I went into the Device Manager, temporarily disabled every device with audio capability (except onboard audio), rebooted, relaunched 2.1.3, and it worked. Not a permanent solution, but at least now we know the cause. Next I will try to determine if one device in particular is the problem.

UPDATE 2: The offending device is my Happauge USB WinTV device. Disabling it allows Audacity to run. I need a fix. There are no newer drivers for this device.
DxDiag.txt (38.9 KB)

It’s best to post a new reply rather than edit an old post. The index page for each Forum board does not show us that a post has been edited, so we might literally never see the new information you added.

I would have guessed that as the likely offender, seeing your DxDiag report.

Unfortunately there is no easy fix. We’re reliant on the PortAudio audio I/O interface that we use as to what devices work and don’t, and which ones hang Audacity if they are incompatible. You already tried 2.1.3-alpha which has a later PortAudio version.

Although it is some work, you could download the Windows Driver Kit (WDK) which gives you devcon.exe (the command-line version of Windows Device Manager). You could create a batch file which first calls devcon.exe with a command to disable Hauppage and then launches Audacity, and a second batch file to re-enable Hauppage.

There is a feature request here that you could create such a device profile in Audacity so that it does not load specific devices if found, but given the few users that would use that feature, and the invasiveness of such a change, it probably won’t happen.


Wont launch on my pc either i’ll post a screenshot of the dynamic link library that is not included in the installer clearly nobody runs a clean win 7 in a virtual machiine, stop posting things that ‘could’ fix it and focus on what actually will fix it please!

Umm this indicates that you didn’t include all necessary files in the installer

If you don’t approve my posts I will not be back to the forums

Thanks for approving my posts, the controversial is more difficult than the normal.

Are you aware that you are replying to a post that is over 3 years old?
Sadly, Gale Andrews will not reply to you as he passed away a few months after that post Missing features - Audacity Support

You are correct that we do not test Audacity on obsolete operating systems.