Audacity will only launch when logged in as administrator

Used earlier versions of Audacity without incident in OS Lion.

Once I upgraded to El Capitan, Audacity wouldn’t launch. It flashes for one second, then fails to launch. Have tried multiple times to do complete uninstall and clean reinstall… same problem. Tried deleting cfg, same problem. Tried other suggested fixes, same problem.

Updated to Mac OS 10.13 (High Sierra) and did clean install of Audacity 2.1.3 from .dmg. Same problem. Then tried launching Audacity while logged in as Administrator and it worked perfectly!?!? Still doesn’t launch when logged in under normal user settings.

Any help would be appreciated. Would like to able to launch and use Audacity when logged in under normal user settings.

Thank you in advance.

Do you have a Virus Protection Program?

As whom did you install it?


Describe the machine. I’m typing on a MacBook Pro, 15" circa 2011, OS-X 10.9.5. Only the local hard drive connected.


Did you install using the graphic installer? Here’s a picture. Drag this into that?


I’m puzzled here because I run a Macbook Pro for Audacity QA testing.

It came originally this year with El Capitan installed and Audacity 2.1.3 (and various alphas for the upcoming 2.2.0) ran on it on
a) my privileged administrator account
b) my standard non-privileged user account
c) mu totally un-privileged guest account

Since then I have upgraded though the various Sierras, including now 10.13 High Sierra - and Audacity 2.1.3 (and 2.2.0 Release Candidate) launches and runs sweetly on all three account levels.

I did have a similar non-launch issue with Audacity flashing in the task bar (but that was with a 2.2.0 alpha and on my admin account). Like Koz I thought at first that that might be down to my virus protection - so I set McAfee to totally trust the Audacity app - but that didn’t cure it. It turned out to be a fault in that alpha, cured in the next alpha release (working even with McAfee trust-Audacity removed).

So I remain puzzled - sorry I can’t be more help.


With Audacity shut down, try trashing everything that’s in:
~/Library/Application Support/audacity/

“~/” means the home directory of the logged-in user.
Note that closing applications does not shut them down. You have to “Quit” the application.

Thanks everyone for your initial help in diagnosing. I’ll try to answer all of the questions in this post, hopefully I’ll cover all the bases.

My machine is a 15" MacBook Pro, mid-2012, OS 10.13, external Time Machine hard drive connected. Each time I’ve installed (or reinstalled) Audacity I’ve done it under my user log-in, not Admin.

For what it’s worth, just unmounted the TIme Machine external drive and double-clicked Audacity to open. Nothing.

I have an older version of Mac Scan for virus/cookie protection. In Lion and Mountain Lion this was also true and not a conflict. It doesn’t run constantly in the background, it needs to be launched and then does a scan, report and isolate.

Did a “Get Info” for Audacity and under my user, it’s “read & write.” For Admin, it’s “read only.” For everyone it’s “read only.”

Koz, I didn’t see a pic attached to your post about graphic installer, so I’m not sure I understand your feedback.

I once again trashed everything in the Library file, no success after that. Note: I don’t have to/can’t close the application to do that; the app never opens when I’m logged in under my normal user name.

I think I covered everything. I’m still puzzled, too. Thanks again.


This is the installer graphic.
Screen Shot 2017-10-27 at 02.14.32.png
It’s a little odd you didn’t recognize it right away in spite of my bad description. You should get this when you double click the Disk Image (dmg).

This is a segment of my Applications folder. I have multiple versions on my machines, so I probably have one extra folder set than you do.
Screen Shot 2017-10-27 at 02.22.18.png
Do you have your regular user set to “administer this computer?”
Screen Shot 2017-10-27 at 02.30.31.png

You upgraded from Lion straight to El Capital and then to High Sierra?

Did you upgrade your disk to the new APFS?

Chances are, you’ve missed a firmware upgrade. Or some other conversion didn’t happen. It sounds as if the permissions on your system aren’t fine. I think it’s time for a clean install…

Alternatively, you could run etre check and post the report here. That might give us an idea what’s going wrong and which old plist files to remove. See here: