audacity warning "cant get core function pointer"

I’ve been using Audacity for so long now I don’t even think I could tell you how long it’s been one of the best resources for my music production but, about 2 maybe 3 months a go Audacity just started to crash on me every time I tried to use it an I had NEVER EVER had a problem with it before. I have uninstalled an reinstalled it about 4 time now I believe to get it back to working order, also I’ve read this board through an through to find an answer but nothing. Today I tried again to reinstall it, it did the normal scan to find all my AU’s/VST’s an then afterward it did something I’ve never seen it do up to this point. It came at me with the message “cant get core function pointer”, what does this mean?!? Can someone help me? I love Audacity an I rely heavily on it in my productions! I’m running a MacBook Pro w/ OS X 10.6.8, a 2.26 Ghz Intel Core 2 Duo an 8 GB RAM. HELP PLEASE!! If you need an more info please ask and thank you.
Thanks again,
Elliott “THE EXEK”

Reinstalling Audacity hardly ever (never) cures anything.
To “reset” Audacity you need to reset the Audacity Preferences. See here for how to do that:

Regarding the sudden onset of this problem, have you recently installed any new plug-ins or other audio software? Audacity may be choking on an incompatible plug-in.

Thanks I’ll try that, an yes I did wipe everything at one point put it all back on an for a couple months afterward is when I finally put Logic Studio 9 back on my system an now that I think about it that most likely happened around the same time. Kind’a a guess, but educated. I remember wanting/needing a function from Logic for a project I was work’n on an that Audacity went out an hasn’t come back since around that time but, I did replace I believe the plug-in folder in my library so that it wouldnt get bogged down.