Audacity vanishes on menu

After recent update, on my i7, when I use Audacity, it vanishes on all menu selections other than ‘New’. When restarted, I get a recovery dialog, but no matter whether I recover or discard, the result is always the same. I get no error messages in the log and no information if I start Audacity from a Bash terminal.

I am using PCLinuxOS 5.14.6
Audacity 3.0.4 - from the synaptic repository.

Interestingly, on my other PCs: 2x i3 desktops and an i3 laptop, with exactly the same configuration, I have no problem.

Any ideas?


Have you tried resetting Audacity?
For a quick reset, use: “Tools menu > Reset Configuration”.

For a full reset:

  1. Close Audacity
  2. Delete

I selected it but Audacity vanished, so I deleted the ~/.audacity and ~/.audacity-data folders, to let it start again without effect.

Didn’t know about /var/tmp/audacity–, I will try that before posting this…
No, It had no effect.

I also reinstalled it, that didn’t do anything either.

I creasted a new profile and tried it in that. It vanished as well, so it isn’t something in my profile. It mus be something with the install. But I am not finding anything in the logs that would indicate what.

Tried running audacity through strace and got this:

writev(2, [{iov_base=“/tmp//.mount_audaciDoLNwD/bin/au”…, iov_len=38}, {iov_base=“: “, iov_len=2}, {iov_base=“symbol lookup error”, iov_len=19}, {iov_base=”: “, iov_len=2}, {iov_base=”/usr/lib64/”, iov_len=26}, {iov_base=“: “, iov_len=2}, {iov_base=“undefined symbol: g_module_open_”…, iov_len=36}, {iov_base=””, iov_len=0}, {iov_base=“”, iov_len=0}, {iov_base=“\n”, iov_len=1}], 10) = 126
exit_group(127) = ?
+++ exited with 127 +++

Perhaps worth trying the new Audacity 3.0.5 AppImage:

Cracked it!

I deleted all the installed Nyquist plugins and back to normal service.