Audacity suddenly stop recording

I have been recording without issues for a while. I was recording files and opened a new file to record and no recording sound was picking up (flatline). I opened old files and they play back ok. Audacity 2.1.3, Windows 7 laptop, USB microphone for recording. I re-installed Audacity, re-booted laptop several times, tried different USB ports, tried recording with the laptop internal mic which isn’t picking up either, checked Control Panel sound settings. Any suggestions? Thanks.

Disconnect the USB mic
Reboot the computer
Plug in the USB mic
Open the Sounds control panel (
Switch to the recording tab, and check that the USB mic is enabled and working. You should see a green meter respond to talking into the mic.

When the above is working:
Launch Audacity
In the “Device Toolbar” (, set “host” to MME and the “recording device” to the USB mic option.
Start recording.

More detailed version here:

Steve, thank you for posting the reply.

After numerous reboots, driver and software un/reinstalls, I ended up doing a BIOS update. My mic still doesn’t work in the USB port I usually use, but it is now recording fine with Audacity in a different USB port (so far). Other devices are working ok in the USB port I was usually using for my mic.