Audacity subliminal Nyquist command, recently producing flat lines


OS: Ubuntu 21.0.4
Audacity: 3.0.4 Appimage

As well as:

Windows 10
Audacity: 3.0.4

I have been using Audacity to make subliminal tracks for about 2 months now. And previously everything seemed fine. After applying subliminal there was not only, an oscillating graph for the result, but there was also volume levels showing activity. But now when I apply subliminal on both Windows and Ubuntu, it shows a graph initially but no volume activity exists when I play the subliminal track alone. Also afterwards if I import the .wav audio into audacity again to check things, it shows a complete flatline - no oscillation.

Any help would be very much appreciated.

I just tried the debug button on the Nyquist Command pop-up window as well. The debug window returned an empty window.

Which Nyquist script / plug-in are you using?

What is the track sample rate? (look in the panel on the left end of the track)

Here is the cntents of the Nyquist Command window that I have pasted there:

;nyquist plug-in
;version 1
;type process
;name "Subliminal..."
;action "Subliminal..."
;control carrier "Carrier" real "Hz" 17500 14000 20000

(setf carrier (max 14000 (min carrier 20000)))

;; We have two Nyquist frequencies, carrier/2 and *sound-srate*/2.
;; The CUTOFF is the maximum allowed frequency in the modulator.
;; It must not be greater than carrier/2, but also not greater than
;; the difference between the carrier and *sound-srate*/2, because
;; otherwise the modulated carrier aliases.

(setf cutoff (min (/ carrier 2.0) (- (/ *sound-srate* 2.0) carrier)))

(defun cut (function sound frequency)
  (dotimes (ignore 10 sound)
    (setf sound (funcall function sound frequency))))

(defun subliminal (sound)
  (let ((result (mult 2 (cut #'lowpass8 (hp sound 80) cutoff)
                        (hzosc carrier))))
    (cut #'highpass8 result carrier)))

(if (< *sound-srate* 44100)
    (princ "The track sample frequency must be minimum 44100Hz.")
    (multichan-expand #'subliminal s))

Like I said, everything used to be fine.

When I import my audio clip it’s 24000 Hz, but I always resample it to 44100 Hz. Actually if I don’t do that Nyquist Prompt won’t function and will throw an error.

Thank you so much for your questions.

1 Like

If you generate a “Chirp” with the settings set at their defaults (shown below) and then apply the Nyquist “subliminal” effect, does that work as expected?

No, it doesn’t work. When I play the subliminalized track in Audacity, there is no volume activity just like with the other tries.

Do you see the waveform in the track?

Try running the effect with the “Debug” button - is there an error message?

Yes, I see the wave. But if I export it and then re-import it, the wave disappears too. Debug results are completely blank. Audacity doesn’t report any errors whatsoever.

What format are you exporting as?
It’s very likely that compressed format such as MP3 will remove the very high frequency content as they are designed to remove inaudible parts of the audio so as to create a smaller file while retaining as much of the audible sound as possible.

I have tried both .wav and MP3 formats. They both produce flat lines. Even if it were because of a format issue, when I play the subliminalized track in Audacity, the volume indicator should show something - like it used to previously -, even though we don’t actually hear the chirp any longer.

What is the “Project Rate” set at? (bottom left corner of the main Audacity window).
Set it to 44100 if it is not that already.

The project rate sets the overall sample rate for the project, so this is the sample rate that is used when playing and exporting.

Yes, that was the problem. Thanks so much Steve. Have a wonderful time wherever you are.