Audacity stuck on loading screen. Worked a few minutes ago

Hi all,

Got up this morning and loaded Audacity 2.10. Imported a .wav file and then saved the project to disk. Everything worked just like normal, as it has every time I’ve opened Audacity.

A few minutes later I went to open Audacity and edit the saved project. However, Audacity doesn’t load. It gets as far as the splash screen with the Audacity logo. But, that’s it. The logo just sits there in the middle of the screen and does nothing. No “Not Responding” message, or anything else for that matter. Let it sit that way for a few minutes before finally force closing the application.

I tried installing the program over the top of itself, and that didn’t help. I even completely uninstalled it, and reinstalled from a freshly downloaded installer from the official rep link on the Audacity page. Still no joy.

Running Windows 10. But, NO updates have been installed to the O/S since last week, and I have used the program multiple times since then, including just this morning, so it’s not O/S related.

Is there some kind of cache I need to delete? (Think of it as Windows 8)



Got up this morning and loaded Audacity 2.10.

I hope not. That’s a bogus version. The latest Audacity is 2.1.0.


Somewhere in the install it will ask you if you want to delete all the preferences and settings. Say yes.


Irrespective if resetting Audacity Preferences solves the problem, Windows 10 is a Preview operating system to which Microsoft is still making changes. Audacity does not support it.

However feel free to let us know of any issues you do find that are related to Windows 10. We can certainly try fixing them nearer the time of Windows 10 release.