Audacity stops working after 40 seconds if it works at all

I’m running windows 10, home addition, nothing special. Recently Audacity has stopped working for me, if I do get it to record it will only do so for about 40 seconds and freezing up once it freezes up everything still works but when you hit record nothing happens, the bar wont move or record anything. I have tried trouble shooting and found no issues aside it telling me to use windows 8, i’m using version 2.3.0 which looks to be the latest version. I have also tried uninstalling and removing all files then reinstalling and that dose not work either, I updated my sound drives and all my other drives are up to date so was there some update for windows 10 that’s causing this or is this a bug. I have to assume it’s a bug because I have found no info on it so far. Please if someone could help me out that would be great. I can’t be the only one this has happened to.

all my other drives

“All your other drives?” How many do you have and how are they connected? Saving live recordings to other than roomy, well-behaved internal drives is not recommended. Saving to network-connected drives is highly not recommended.

I can’t be the only one this has happened to.

Most people don’t have multiple operating drives. Backup, safety, temp and archive, yes, but not operating.


Who is right?
Right about what?